Bug 237367 - yum-downloadonly plugin's --downloaddir option generates stack backtrace
yum-downloadonly plugin's --downloaddir option generates stack backtrace
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-21 06:47 EDT by Debarshi Ray
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-21 08:02:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This trivial change fixes this issue for me. (428 bytes, patch)
2007-04-21 06:47 EDT, Debarshi Ray
no flags Details | Diff

  None (edit)
Description Debarshi Ray 2007-04-21 06:47:18 EDT
Description of problem:

Using the --downloaddir option in yum-downloadonly plugin generates a stack
backtrace due to an AttributeError.

Version-Release number of selected component (if applicable):

yum-downloadonly-1.0.3-1.fc6.noarch.rpm   from Fedora Extras; and yum-3.0.3

How reproducible:

Everytime.

Steps to Reproduce:

1. Enable plugins in YUM and provide the --downloadonly option to YUM to
activate the yum-downloadonly plugin.

2. Use the --downloaddir option to YUM to change the default download directory.

3. Run YUM.

eg., # yum --downloadonly --downloaddir=/tmp/foo install R-devel

Actual results:

You get a stack backtrace due to a AttributeError caused by the following
statement on line number 38 in /usr/lib/yum-plugins/downloadonly.py:
repo.set('pkgdir',opts.dldir)

Expected results:

One would expect YUM to obediently download all the packages in the specified
directory.

Additional info:

The exception is raised since 'repo' is an instance of 'YumRepository' and it
has no member function named 'set'. What it has instead is 'setAttribute'.

Please find attached a patch
(http://glug-nith.org/~rishi/download/src/downloadonly.diff) I used to fix this
issue on my system.
Comment 1 Debarshi Ray 2007-04-21 06:47:18 EDT
Created attachment 153236 [details]
This trivial change fixes this issue for me.
Comment 2 Tim Lauridsen 2007-04-21 08:02:57 EDT
Thanks, i have fixed it upstream

Note You need to log in before you can comment on or make changes to this bug.