Bug 237438 - dmraid fails to detect at boot
dmraid fails to detect at boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Broz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-22 22:55 EDT by Need Real Name
Modified: 2013-02-28 23:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-26 09:56:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-04-22 22:55:45 EDT
Description of problem:
dmraid (not root partition) is failing to detect at boot.  The function
resolve_dm_name() in /etc/init.d/functions called by /etc/rc.sysinit, depends on
"dmsetup table" to return available devices but "dmsetup table" seems to only
see already active devices, thus a chicken or egg situation where no device is
returned for activation.

Version-Release number of selected component (if applicable):
dmraid-1.0.0.rc13
initscripts-8.45.7-1

How reproducible:
Create a hardware based raid utilizing dmraid.  Reboot.

Steps to Reproduce:
1.Create a raid utilizing "fakeraid" hardware.
2.Test for active raid devices, dmraid -tay
3.reboot
  
Actual results:
Although /etc/rc.sysinit is supposed to pass the available raid devices to
dmraid to activate via resolve_dm_name(), they fail to get recognized and the
raid device does not get created under /dev/mappper.

Expected results:


Additional info:
Comment 1 Need Real Name 2007-04-23 01:09:11 EDT
Ah, I figured it out and resolved my problem by updating the initrd.
I would not have thought that it would require a mkinitrd to set up to use
fakeraid drivers for a non-root partition.  Technically, not a bug, although I'd
think m'be the design could be better.  That is, unless I'm missing something.
Comment 2 Milan Broz 2007-04-26 09:56:18 EDT
Init script expect already existing dm device.
mkinitrd also prepare possible kernel modules for underlying storage drivers.
If you think that it is bug, please report/reopen bug to initscripts component.

Note You need to log in before you can comment on or make changes to this bug.