Bug 23751 - PHP not compiled with IMAP support
Summary: PHP not compiled with IMAP support
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-10 22:45 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-08 00:00:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-01-10 22:45:52 UTC
[root@scootz inc]# rpm -q php mod_php php-imap
php-4.0.3pl1-1
mod_php-4.0.3pl1-1
php-imap-4.0.3pl1-1

I'm trying to get some php scripts to work but they require IMAP support 
be compiled into PHP. I for the life of me can't get it to work.

I keep getting the error:
Fatal error: Call to undefined function: imap_open()

Comment 1 Nalin Dahyabhai 2001-01-23 17:57:46 UTC
Please check that the line:
extension=imap.so
is not commented out in /etc/php.ini.

Comment 2 Need Real Name 2001-01-30 14:07:51 UTC
[root@scootz /etc]# cat php.ini | grep -i imap
extension=imap.so


Yep, it's there. Still having issues.

Comment 3 Nalin Dahyabhai 2001-01-30 21:18:47 UTC
I am unable to reproduce this with apache-1.3.14-3 and the php-4.0.3pl1-1 errata
packages.  A call to imap_open like this:

<? $imap = imap_open("{myserver}INBOX", "nalin", "wrongpass", 0); ?>

Returns an error:
Warning: Couldn't open stream {myserver}INBOX in /var/www/html/imaptest.php on
line 1

How are you calling the function?

Comment 4 Need Real Name 2001-01-30 23:04:48 UTC
Using the package PHPGroupWare (http://www.phpgroupware.org) Happens with the 
latest release as well as the CVS version.

function open($mailbox,$username,$password,$flags="")
    {
      return imap_open($mailbox,$username,$password,$flags);
    }

Comment 5 Need Real Name 2001-02-01 01:16:26 UTC
Upgraded to php-4.0.4pl1-3 and it works fine now.

Comment 6 Nalin Dahyabhai 2001-02-02 06:03:07 UTC
If you have a chance, please try the packages (currently 4.0.4pl1-5) in
http://people.redhat.com/nalin/test/, which are currently errata candidates.  If
everything continues working, I'll be ecstatic and close this one out as fixed
in an errata.

Thanks!

Comment 7 Bill Nottingham 2001-12-08 03:33:04 UTC
closing as fixed in 4.0.4pl1-3 errata.


Note You need to log in before you can comment on or make changes to this bug.