Bug 237515 - INFO: inconsistent lock state
INFO: inconsistent lock state
Status: CLOSED DUPLICATE of bug 232340
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-23 12:19 EDT by Orion Poplawski
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-23 12:38:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-04-23 12:19:40 EDT
Description of problem:

During install:

<4>=================================
<4>[ INFO: inconsistent lock state ]
<4>2.6.20-1.3094.fc7 #1
<4>---------------------------------
<4>inconsistent {hardirq-on-W} -> {in-hardirq-W} usage.
<4>swapper/0 [HC1[1]:SC0[0]:HE0:SE1] takes:
<4> (&port_lock_key){++..}, at: [<c0558f96>] serial8250_interrupt+0x4a/0xe0
<4>{hardirq-on-W} state was registered at:
<4>  [<c044021d>] __lock_acquire+0x448/0xba9
<4>  [<c0440d70>] lock_acquire+0x56/0x6f
<4>  [<c060ffd1>] _spin_lock+0x2b/0x38
<4>  [<c055893b>] serial8250_backup_timeout+0x6d/0xe8
<4>  [<c042c972>] run_timer_softirq+0x121/0x189
<4>  [<c0429dfb>] __do_softirq+0x6f/0xe2
<4>  [<c0407a64>] do_softirq+0x61/0xd0
<4>  [<ffffffff>] 0xffffffff
<4>irq event stamp: 332718
<4>hardirqs last  enabled at (332717): [<c0403dde>] default_idle+0x3e/0x59
<4>hardirqs last disabled at (332718): [<c0406054>] common_interrupt+0x24/0x40
<4>softirqs last  enabled at (332708): [<c0429e68>] __do_softirq+0xdc/0xe2
<4>softirqs last disabled at (332691): [<c0407a64>] do_softirq+0x61/0xd0
<4>
<4>other info that might help us debug this:
<4>1 lock held by swapper/0:
<4> #0:  (&irq_lists[i].lock){+...}, at: [<c0558f61>] serial8250_interrupt+0x15/0xe0
<4>
<4>stack backtrace:
<4> [<c0406832>] show_trace_log_lvl+0x1a/0x2f
<4> [<c0406df1>] show_trace+0x12/0x14
<4> [<c0406e75>] dump_stack+0x16/0x18
<4> [<c043ed13>] print_usage_bug+0x141/0x14b
<4> [<c043f402>] mark_lock+0xa2/0x419
<4> [<c044018e>] __lock_acquire+0x3b9/0xba9
<4> [<c0440d70>] lock_acquire+0x56/0x6f
<4> [<c060ffd1>] _spin_lock+0x2b/0x38
<4> [<c0558f96>] serial8250_interrupt+0x4a/0xe0
<4> [<c045699a>] handle_IRQ_event+0x1a/0x46
<4> [<c0457a8a>] handle_fasteoi_irq+0x7d/0xb6
<4> [<c0407b84>] do_IRQ+0xb1/0xd9
<4> =======================
Comment 1 Orion Poplawski 2007-04-23 12:38:01 EDT

*** This bug has been marked as a duplicate of 232340 ***

Note You need to log in before you can comment on or make changes to this bug.