Bug 237646 - Anaconda insists on a network configuration for every ethernet card
Anaconda insists on a network configuration for every ethernet card
Status: CLOSED DUPLICATE of bug 218200
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-24 10:14 EDT by Steve Whitehouse
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 13:52:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Whitehouse 2007-04-24 10:14:04 EDT
Description of problem:

Installing RHEL 5 (as per the version on porkchop) (i.e.
RHEL5-Server-20070208.0-x86_64-disc1-ftp.iso et al.) on a Dell Poweredge 1850
server. After configuration of eth0, anaconda insists that eth1 also requires
either an ipv4 or ipv6 address or both. It ought to be possible to leave the
network devices unconfigured if required


How reproducible:

Every time.

Steps to Reproduce:
1. Install RHEL 5.0 on a machine with >1 ethernet cards
2. Attempt to leave one of the cards unconfigured.
  
Actual results:

Impossible to move to next stage of the installation without configuring all of
the network cards. Also if I move back to the configuration of the first card
from the config screen for the second card, then it changes the configuration
back to the default (get address from DHCP) rather than what I'd previously
configured (set ipv4 address manually). I would have expected it to have
retained the previously assigned configuration.

Expected results:

Should carry on and ignore the unconfigured network card.
Comment 1 David Cantrell 2007-04-24 10:38:25 EDT
This sounds like text mode.  Either way, the network configuration interfaces
(both text and graphical) in RHEL5 are just a bit stupid in some instances. 
Need to rewrite the loops for a lot of that stuff.  Have it all fixed in
rawhide, just need to pull over the relevant code for RHEL-5.1.
Comment 2 Steve Whitehouse 2007-04-24 10:43:08 EDT
Yes, it is text mode, sorry, I should have mentioned that in the report.
Comment 3 David Cantrell 2007-07-24 13:52:13 EDT

*** This bug has been marked as a duplicate of 218200 ***

Note You need to log in before you can comment on or make changes to this bug.