Bug 237669 - gaim-otr needs updating to follow gaim -> pidgin name transition
gaim-otr needs updating to follow gaim -> pidgin name transition
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gaim-otr (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-24 13:06 EDT by Bryan O'Sullivan
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-11 18:17:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to make gaim-otr build for Pidgin (66.91 KB, patch)
2007-05-11 13:57 EDT, Stu Tomlinson
no flags Details | Diff

  None (edit)
Description Bryan O'Sullivan 2007-04-24 13:06:17 EDT
The gaim-otr plugin doesn't work in rawhide, because pidgin (new name for gaim)
doesn't look in %{_libdir}/gaim any longer.
Comment 1 Paul Wouters 2007-04-24 22:56:29 EDT
YEs, I'm aware of it and working on getting this fixed. I'm running into other
issues when building inside mock and am talking to upstream to get it resolved.
Comment 2 Paul Wouters 2007-05-06 23:25:40 EDT
Upstream released a new version today that should build with pidgin. I'm going
to build and package this tomorrow.
Comment 3 Stu Tomlinson 2007-05-11 13:57:24 EDT
Created attachment 154558 [details]
Patch to make gaim-otr build for Pidgin

The attached patch (against gaim-otr Fedora devel CVS) makes gaim-otr build and
load with Pidgin. It does not rename the package to pidgin-otr or any other
sensible things like that.
Comment 4 Paul Wouters 2007-05-11 17:11:50 EDT
I've just applied the patch from Stu (Thanks!) and send off a build request
which seemed to have succeeded. So if anyone wants to try
gaim-otr-3_0_1-0_6_20060712cvs_fc7 nad let me know if it works, that would be
great, so then I can ask for it to be included in F7.
Comment 5 Bryan O'Sullivan 2007-05-11 17:16:31 EDT
gaim-otr-3.0.1-0.6.20060712cvs.fc7.x86_64.rpm works for me.  Thanks!
Comment 6 Bryan O'Sullivan 2007-05-11 17:17:18 EDT
By the way, you might want to rename the package to pidgin-otr, and obsolete the
old gaim-otr name.
Comment 7 Paul Wouters 2007-05-11 18:07:55 EDT
I will rename the package only once upstream has released a version that it has
renamed.

Thanks for testing!
Comment 8 Luke Macken 2007-05-11 18:50:52 EDT
Works for me.

Note You need to log in before you can comment on or make changes to this bug.