Bug 237764 - Some extra Dell Latitude Fn+ keys don't show up in user space
Some extra Dell Latitude Fn+ keys don't show up in user space
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 203664 (view as bug list)
Depends On:
Blocks: 202880 237760
  Show dependency treegraph
 
Reported: 2007-04-25 06:30 EDT by Bastien Nocera
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 08:44:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2007-04-25 06:30:39 EDT
kernel-2.6.20-1.3104.fc7

Some keys on the Dell Latitude D420 don't have any keycodes associated to them.

What the keys do is explained at:
http://support.euro.dell.com/support/edocs/systems/latd420/en/PG124en1/keyboard.htm#wp1050757

Fn+F3 (power preferences?):
Apr 25 11:23:10 snoogens kernel: atkbd.c: Unknown key pressed (translated set 2,
code 0x87 on isa0060/serio0).
Apr 25 11:23:10 snoogens kernel: atkbd.c: Use 'setkeycodes e007 <keycode>' to
make it known.

Fn+F7 (change display aspect ratio):
Apr 25 11:23:33 snoogens kernel: atkbd.c: Unknown key pressed (translated set 2,
code 0x8f on isa0060/serio0).
Apr 25 11:23:33 snoogens kernel: atkbd.c: Use 'setkeycodes e00f <keycode>' to
make it known.

Fn+F8 (CRT/LCD):
Apr 25 11:24:01 snoogens kernel: atkbd.c: Unknown key pressed (translated set 2,
code 0x8b on isa0060/serio0).
Apr 25 11:24:01 snoogens kernel: atkbd.c: Use 'setkeycodes e00b <keycode>' to
make it known.

Fn+Up (Brightness up):
Apr 25 11:24:36 snoogens kernel: atkbd.c: Unknown key pressed (translated set 2,
code 0x86 on isa0060/serio0).
Apr 25 11:24:36 snoogens kernel: atkbd.c: Use 'setkeycodes e006 <keycode>' to
make it known.

Fn+Down (Brightness down):
Apr 25 11:24:54 snoogens kernel: atkbd.c: Unknown key pressed (translated set 2,
code 0x85 on isa0060/serio0).
Apr 25 11:24:54 snoogens kernel: atkbd.c: Use 'setkeycodes e005 <keycode>' to
make it known.

Fn+Left (Auto brightness):
Apr 25 11:25:11 snoogens kernel: atkbd.c: Unknown key pressed (translated set 2,
code 0x93 on isa0060/serio0).
Apr 25 11:25:11 snoogens kernel: atkbd.c: Use 'setkeycodes e013 <keycode>' to
make it known.
Comment 1 Bastien Nocera 2007-04-25 10:30:51 EDT
And another key.

Fn+F1 (Hibernate):
Apr 25 15:29:48 snoogens kernel: atkbd.c: Unknown key pressed (translated set 2,
code 0x8a on isa0060/serio0).
Apr 25 15:29:48 snoogens kernel: atkbd.c: Use 'setkeycodes e00a <keycode>' to
make it known.
Comment 2 Richard Hughes 2007-04-25 10:41:48 EDT
Bastien. I think we are correct, hal-info would allow us to push these as fixes
very easily. I'm not able to hack on this for a few days (exams coming up) but
could you start to collect some DMI data and keys? I think we just need to match
on DMI vendor, rather than fine grained per-laptop matching.

We can fix this in very few lines of code IMO.
Comment 3 Bastien Nocera 2007-04-25 10:46:01 EDT
(In reply to comment #2)
> Bastien. I think we are correct, hal-info would allow us to push these as fixes
> very easily. I'm not able to hack on this for a few days (exams coming up) but
> could you start to collect some DMI data and keys? I think we just need to match
> on DMI vendor, rather than fine grained per-laptop matching.
> 
> We can fix this in very few lines of code IMO.

Very likely, but I'd rather hear from the kernel maintainers first. I wonder
whether this would be fixable at the kernel level rather than needing to add
this to userspace itself.
Comment 4 Bastien Nocera 2007-05-29 17:41:11 EDT
*** Bug 203664 has been marked as a duplicate of this bug. ***
Comment 5 Bastien Nocera 2007-05-30 07:03:54 EDT
From:
http://thread.gmane.org/gmane.linux.kernel.input/1638

So we'd need to fix this in user-space, as it wouldn't be accepted in the kernel.
Comment 6 Bastien Nocera 2007-06-05 14:17:46 EDT
An example on how to implement it on a Dell Latitude D420:
http://lists.freedesktop.org/archives/hal/2007-June/008697.html
Comment 7 Bastien Nocera 2007-08-20 08:44:22 EDT
Already done in git master of hal-info, closing.

Note You need to log in before you can comment on or make changes to this bug.