Bug 237773 - pkgpolicy in yum.conf is not documented in online manual
pkgpolicy in yum.conf is not documented in online manual
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.0
All Linux
medium Severity low
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-25 07:54 EDT by masanari iida
Modified: 2008-05-21 10:20 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0388
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:20:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description masanari iida 2007-04-25 07:54:44 EDT
Description of problem:
pkgpolicy in yum.conf  is not documented in online manual

Version-Release number of selected component (if applicable):

yum-3.0.1-5.el5

How reproducible:
Always

Steps to Reproduce:
1. man yum.conf
2. find pkgpolicy
  
Actual results:
I can not find pkgpolicy section of the man. 

Expected results:
I should find pkgpolicy section of the man.

Additional info:
Currently pkgpolicy=newest is set as a default.
This is sufficient for most of the user.
But from customer support engineer's point of view, we sometimes
want to download older version of RPMs  or debuginfo-RPM.
So that's why I would like to know what else I can set in
this parapeters other than "newest".
This is the reason why I want to read the man page.
I expect there is a parameter such as pkgpolicy=all (all generations)
Comment 1 Jeremy Katz 2007-04-25 11:17:54 EDT
pkgpolicy actually doesn't exist any more; the fact that it's still in the
config is a remnant of days gone past.  I've gone ahead and nuked it to avoid
confusion in the future.
Comment 2 RHEL Product and Program Management 2007-04-25 11:25:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 masanari iida 2007-04-25 22:25:46 EDT
Thanks for the answer.
I found one-line comment that pkgpolicy option was removed on March/2005.

One more minor error that I found in yum.conf manual is in "keepcache"
section. It is said "Default value is 1.(keep files)".
But on RHEL5  and Fedora Core 5, the default value of keepcache is 
set to 0.
Comment 8 James Antill 2008-02-03 21:49:50 EST
 This has been removed in the RHEL-5.2 configuration file.
Comment 9 RHEL Product and Program Management 2008-02-03 21:56:54 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 Jan Hutař 2008-04-16 08:14:05 EDT
Moving to VERIFIED: On clean install of yum package there is no 'pkgpolicy' 
option in the /etc/yum.conf.
Comment 14 errata-xmlrpc 2008-05-21 10:20:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0388.html

Note You need to log in before you can comment on or make changes to this bug.