This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 237791 - Should disable Power button when Lid used to suspend
Summary: Should disable Power button when Lid used to suspend
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 237760
TreeView+ depends on / blocked
 
Reported: 2007-04-25 14:09 UTC by Bastien Nocera
Modified: 2015-03-05 01:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 12:39:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bastien Nocera 2007-04-25 14:09:46 UTC
The Dell designers had the great idea of putting the power button on the outside
of the laptop, rather than protected by the lid.

So when suspended, it's possible that the laptop will wake up during transport
with the power button being accidentally pressed.

When the lid is closed, the power button should be disabled as an ACPI wake up
device.

The power button:
http://support.euro.dell.com/support/edocs/systems/latd420/en/PG124en1/about.htm#wp1223065

Comment 1 Bastien Nocera 2007-04-25 14:11:42 UTC
I obviously forgot to mention that the laptop was a Dell Latitude D420

Comment 2 David Zeuthen 2007-05-01 17:11:58 UTC
Is this even possible? It's also probably better to do this from HAL since you
want all the quirks in one central place...

Comment 3 Bastien Nocera 2007-05-22 12:39:01 UTC
The power button doesn't do anything when the lid is closed. Fixed in hardware!


Note You need to log in before you can comment on or make changes to this bug.