Bug 237803 - Graphicsmagick gm binary segfaults on image rendering x86_64 & X86
Summary: Graphicsmagick gm binary segfaults on image rendering x86_64 & X86
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: GraphicsMagick (Show other bugs)
(Show other bugs)
Version: 6
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Andreas Thienemann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-25 14:54 UTC by Matt Darcy
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.1.8-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 17:05:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack Trace of the error (1.88 KB, application/octet-stream)
2007-04-25 14:54 UTC, Matt Darcy
no flags Details

Description Matt Darcy 2007-04-25 14:54:27 UTC
Description of problem:
While configuring the gallery2 product (external to Fedora) I discovered the 
command being called to make thumbnails was causing a segfault of the "gm" 
binary. I have verified this both using gallery2 to call the command and 
calling it from the command line. I have also verified this on two x86_64 
builds both fully patched and up to date. One on a core 2 duo chip and the 
other on an amd64 platform. 
I have been unable to verify this bug using the rpm-installed gallery2 package 
due to restrictions on the machine. I suspect this should behave the same as 
the problem is the call to the gm binary.
This issue also occurs in x86

Version-Release number of selected component (if applicable):
GraphicsMagick-1.1.7-7

How reproducible:
Every time

Steps to Reproduce:
1. Install GraphicsMagick 1.1.7-7 and dependencies
2. move to a a graphics file
3. issue the following command "/usr/bin/gm composite -geometry +0+0 
source_image.jpg destination_image.jpg"
substitute source_image.jpg with the name of an image and destination_image.jpg 
with a random output image file name
Actual results:
Segmentation fault

[quote from syslog]
Apr 25 15:22:36 berger kernel: gm[18521]: segfault at 0000000000000050 rip 
000000325e0ecdeb rsp 00007ffff60a8990 error 4
[end quote from syslog]

Expected results:
Image to be re-rendered.

Additional info:

Comment 1 Matt Darcy 2007-04-25 14:54:27 UTC
Created attachment 153426 [details]
Stack Trace of the error

Comment 2 Matt Darcy 2007-05-21 12:33:29 UTC
hi, 

is this bug going to be looked at, its still classed as "new"

Comment 3 Andreas Thienemann 2007-07-28 15:09:15 UTC
There is a 1.1.8 maintenance release planned for this weekend by the GM maintainer.

It is assumed that this problem will be fixed in the upcoming gm package.

Comment 4 Fedora Update System 2007-07-30 17:05:14 UTC
GraphicsMagick-1.1.8-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.