Bug 23783 - console install problem under CJK.
console install problem under CJK.
Status: CLOSED DUPLICATE of bug 23784
Product: Red Hat Raw Hide
Classification: Retired
Component: anaconda (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-11 05:03 EST by Won-kyu Park
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-11 11:54:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Won-kyu Park 2001-01-11 05:03:35 EST
Under CJK env. with textconsole installation(without kon2)

anaconda show multi-byte character with terrible crushed messages.


This is a proposal for work-around this problem.

(also used by who want to install RH Linux with a specific language)

Simply, type below command at the boot time syslinux prompt:

- normal: linux LANG=ko <enter>
- with above patch: linux LANG=ko LANGUAGE=en <enter>
 (maybe configured in syslinux.cfg)


------------------8X----------------
diff -ur anaconda-7.1/loader/loader.c anaconda-7.1.my/loader/loader.c
--- anaconda-7.1/loader/loader.c        Thu Dec 21 07:50:20 2000
+++ anaconda-7.1.my/loader/loader.c     Thu Jan 11 17:53:45 2001
@@ -1980,6 +1980,8 @@
         } else if (!strncasecmp(argv[i], "ks=file:", 8)) {
            flags |= LOADER_FLAGS_KSFILE;
            *ksSource = argv[i] + 8;
+       } else if (!strncasecmp(argv[i], "language=", 9)) {
+           setenv("LANGUAGE",argv[i] + 9, 1);
        } else if (!strncasecmp(argv[i], "lang=", 5)) {
            /* For Japanese, we have two options.  We should just
               display them so we don't have to start kon if it is not
needed. *
/
diff -ur anaconda-7.1/text.py anaconda-7.1.my/text.py
--- anaconda-7.1/text.py        Thu Jan  4 06:11:30 2001
+++ anaconda-7.1.my/text.py     Thu Jan 11 17:55:03 2001
@@ -91,7 +91,10 @@
         newlangs = [lang]
        if len(lang) > 2:
             newlangs.append(lang[:2])
-        cat.setlangs (newlangs)
+        if os.environ.has_key ("LANGUAGE"):
+            cat.setlangs ([os.environ["LANGUAGE"][:2]])
+        else:
+           cat.setlangs (newlangs)
         todo.language.set (choice)

        if not todo.serial:
@@ -884,7 +887,9 @@
         self.dir = 1
        signal.signal(signal.SIGINT, signal.SIG_IGN)
        signal.signal(signal.SIGTSTP, signal.SIG_IGN)
-        if os.environ.has_key ("LC_ALL"):
+        if os.environ.has_key ("LANGUAGE"):
+            cat.setlangs ([os.environ["LANGUAGE"][:2]])
+       elif os.environ.has_key ("LC_ALL"):
             cat.setlangs ([os.environ["LC_ALL"][:2]])

     def __del__(self):
----------------------8X----------------
Comment 1 Matt Wilson 2001-01-26 21:31:39 EST

*** This bug has been marked as a duplicate of 23784 ***

Note You need to log in before you can comment on or make changes to this bug.