Bug 237834 - After install, /root has default_t context
Summary: After install, /root has default_t context
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-25 15:40 UTC by Orion Poplawski
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 19:07:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Orion Poplawski 2007-04-25 15:40:45 UTC
Description of problem:

After install, /root and contents have default_t context rather than
user_home_dir_t for /root and user_home_t for contents.

Version-Release number of selected component (if applicable):
anaconda-11.2.0.55-1

Comment 1 Chris Lumens 2007-04-25 19:07:17 UTC
That's because anaconda makes /root pretty early, and we have to add it to the
list of things to set the context on manually.  This will be fixed in the next
build.

Comment 2 Orion Poplawski 2007-04-25 19:22:58 UTC
Looks like you may need to do /home too:

drwxr-xr-x  root root system_u:object_r:default_t      home



Note You need to log in before you can comment on or make changes to this bug.