Bug 237852 - sound doesn't properly work with f-u-switching/ConsoleKit (dmix)
sound doesn't properly work with f-u-switching/ConsoleKit (dmix)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: multi-user-desktop
  Show dependency treegraph
 
Reported: 2007-04-25 14:25 EDT by Bill Nottingham
Modified: 2014-03-16 23:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 16:58:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-04-25 14:25:46 EDT
Note: this bug may end up being fixed somewhere else.

Description of problem:

If you have one user that logs in on the desktop, ConsoleKit grants them ACL
access to the sound device. They then start a mixer applet, and potentially
other apps that use the sound device.

You then use fast-user-switching to switch to another user. ConsoleKit then
grants this new user ACL access to the sound device. So, apps then open the
sound device...

... and all fail, because they do not have the proper dmix IPC key to talk to dmix.

Some exit with an error (play). Some produce no sound (flash player). Some hang
(rhythmbox). In any case, it's bad.

Version-Release number of selected component (if applicable):

alsa-utils-1.0.14-0.5.rc2.fc7
fast-user-switch-applet-2.17.4-4.fc7
ConsoleKit-0.2.1-2.fc7
Comment 1 David Zeuthen 2007-04-25 14:48:22 EDT
(In reply to comment #0)
> Note: this bug may end up being fixed somewhere else.
> 
> Description of problem:
> 
> If you have one user that logs in on the desktop, ConsoleKit grants them ACL
> access to the sound device. They then start a mixer applet, and potentially
> other apps that use the sound device.

Actually HAL does but that's besides the points.

> ... and all fail, because they do not have the proper dmix IPC key to talk to
dmix.
> 
> Some exit with an error (play). Some produce no sound (flash player). Some hang
> (rhythmbox). In any case, it's bad.

Quite clearly an ALSA bug wouldn't you agree? Anyway, the solution, however, I
think lies elsewhere: PulseAudio. Reassigning to alsa-utils regardless.

I've also bug 237860 to track these issues (another one is that DRI only works
on the first session)
Comment 2 Martin Stransky 2008-02-22 05:57:17 EST
PulseAudio should handle it now, right?
Comment 3 Lubomir Kundrak 2008-02-28 13:21:51 EST
Right. This problem disappears once gnome volume control is replaced with
pavucontrol.
Comment 4 Lennart Poettering 2008-03-28 16:58:17 EDT
g-v-c already can access the PA mixer thorugh gst. I think this problem is fixed
now.

Note You need to log in before you can comment on or make changes to this bug.