Bug 237877 - kernel panic if pci=noacpi
kernel panic if pci=noacpi
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-25 16:12 EDT by Riku Seppala
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 3111
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 12:33:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Riku Seppala 2007-04-25 16:12:02 EDT
Description of problem:
kernel panic if boot with pci=noacpi.

ACPI: Core revision 20070126
ACPI:  setting ELCR to 0ea0 (from 0ca0)
ExtINT not setup in hadrware but reported by MP table
Kernel panic - not syncing: IO-APIC + timer doesen't work! Try using the
'noapic' kernel parameter 

Version-Release number of selected component (if applicable):
kernel-2.6.20-1.3110.fc7.x86_64.rpm  

How reproducible:
allways

Steps to Reproduce:
1. boot with pci=noacpi
2.
3.
  
Actual results:
kernel panic

Expected results:
normal bootup

Additional info:
Last working kernel was 3101. HP Pavilion laptop dv9000 series (dv9237eu). AMD
Turion 64 X2. pci=noacpi noapic works, can't boot without pci=noacpi because of
this http://bugzilla.kernel.org/show_bug.cgi?id=8186
Comment 1 Riku Seppala 2007-04-26 03:46:13 EDT
Correction! It is NOT always reproducible. With 3110 it worked several times,
maybe 12-15 attempts.

3111 seems to work fine, no panic yet.
Comment 2 Riku Seppala 2007-05-08 12:33:01 EDT
I'll change this to current release since I only saw this with 3104 and 3110 and
never since.

Note You need to log in before you can comment on or make changes to this bug.