Bug 237902 - m2crypto m2xmlrpclib does not set a _use_datetime in it's SSL_Transport object
Summary: m2crypto m2xmlrpclib does not set a _use_datetime in it's SSL_Transport object
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: m2crypto   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL: https://bugzilla.osafoundation.org/sh...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-25 22:46 UTC by Adrian Likins
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 0.17-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-26 23:14:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to m2xmlrpclib.py (644 bytes, text/x-patch)
2007-04-25 22:46 UTC, Adrian Likins
no flags Details

Description Adrian Likins 2007-04-25 22:46:12 UTC
Description of problem

got this traceback while testing virt-factory stuff on rawhide

Traceback (most recent call last):
  File "/usr/bin/vf_nodecomm", line 13, in <module>
    nodecomm.main(sys.argv)
  File
"/usr/lib/python2.5/site-packages/virt-factory/server/modules/nodecomm.py", line
84, in main
    rc = handle.call(*real_args)
  File "/usr/lib64/python2.5/xmlrpclib.py", line 1147, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.5/xmlrpclib.py", line 1437, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.5/site-packages/M2Crypto/m2xmlrpclib.py", line 62, in
request
    return self.parse_response(h.getfile())
  File "/usr/lib64/python2.5/xmlrpclib.py", line 1309, in parse_response
    return self._parse_response(file, None)
  File "/usr/lib64/python2.5/xmlrpclib.py", line 1324, in _parse_response
    p, u = self.getparser()
  File "/usr/lib64/python2.5/xmlrpclib.py", line 1210, in getparser
    return getparser(use_datetime=self._use_datetime)
AttributeError: SSL_Transport instance has no attribute '_use_datetime'


It looks like the patch here:
http://sourceforge.net/tracker/index.php?func=detail&aid=1120353&group_id=5470&atid=305470

which made it into python2.5, causes m2crypto's xmlrpclib to break. 

looks like setting self._use_datetime in the Transport class in
/usr/lib64/python2.5/site-packages/M2Crypto/m2xmlrpclib.py  causes this to work.


python-2.5-11.fc7
m2crypto-0.17-1

Comment 1 Adrian Likins 2007-04-25 22:46:12 UTC
Created attachment 153466 [details]
patch to m2xmlrpclib.py

Comment 2 Miloslav Trmač 2007-04-26 23:14:36 UTC
Fixed slightly differently in rawhide m2crypto-0.17-2.  Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.