Bug 237962 - stunnel don't sent client certificate CA names
Summary: stunnel don't sent client certificate CA names
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: stunnel   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact: Brian Brock
URL: http://stunnel.mirt.net/flyspray/?do=...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-26 11:57 UTC by Peter Bieringer
Modified: 2008-03-28 13:54 UTC (History)
1 user (show)

Fixed In Version: 4.22-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 13:54:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Enable sending the client CA list (581 bytes, patch)
2007-04-27 03:16 UTC, Miloslav Trmač
no flags Details | Diff

Description Peter Bieringer 2007-04-26 11:57:20 UTC
Description of problem:
During investigation, why thunderbird does not filter the client certificate on
an via stunnel SSL-enabled IMAP server (which requires client certificate
authentication) it was found out, that stunnel don't send client certificate CA
names, while "openssl s_server" does with similar configuration.

This would lead to selection of the client cert on each IMAP connect, e.g.
selecting a subfolder and so on.

Version-Release number of selected component (if applicable):
stunnel-4.15-2
openssl-0.9.8b-8.3.fc6
stunnel-4.20-2 does not improve the situation.

How reproducible:
Always

Steps to Reproduce:

Using stunnel:

client = no
connect = localhost:imap
CAfile = /etc/pki/ca-cert.crt
cert = /etc/pki/server-cert.crt
key = /etc/pki/server-key.pem
ciphers = MEDIUM:HIGH:!ADH:!SSLv2
verify = 2
service = imap-stunnel

openssl s_client shows:

subject=/CN=gatemuc.muc.bieringer.de/C=DE/L=Munich/O=Peter
Bieringer/OU=Gateways/emailAddress=pb@bieringer.de
issuer=/CN=Certificate Authority/C=DE/L=Munich/O=Peter Bieringer/OU=Certificate
Authority/emailAddress=pb@bieringer.de
---
No client certificate CA names sent
---


Using openssl_server for tests instead with same(!) configuration:

# openssl s_server -accept 993 -cert /etc/pki/server-cert.crt -key
/etc/pki/server-key.pem -CAfile /etc/pki/ca-cert.crt -verify 2


openssl s_client shows:

subject=/CN=gatemuc.muc.bieringer.de/C=DE/L=Munich/O=Peter
Bieringer/OU=Gateways/emailAddress=pb@bieringer.de
issuer=/CN=Certificate Authority/C=DE/L=Munich/O=Peter Bieringer/OU=Certificate
Authority/emailAddress=pb@bieringer.de
---
Acceptable client certificate CA names
/CN=Certificate Authority/C=DE/L=Munich/O=Peter Bieringer/OU=Certificate
Authority/emailAddress=pb@bieringer.de
---


Additional info:

See also discussion on mozilla bugzilla:
https://bugzilla.mozilla.org/show_bug.cgi?id=327001

Comment 1 Miloslav Trmač 2007-04-27 03:16:14 UTC
Created attachment 153574 [details]
Enable sending the client CA list

Thanks for your report.  Sending of the list was disabled for some reason in
stunnel-4.00, I have asked about the reason on the stunnel list.

Comment 2 Peter Bieringer 2007-04-27 05:36:11 UTC
If not enabled in the future by default, there should be at least a config
option to enable this by user without recompiling.

Comment 3 Miloslav Trmač 2008-03-28 13:54:13 UTC
stunnel-4.22, which includes the fix, was built for rawhide.  Thanks again for
your report.


Note You need to log in before you can comment on or make changes to this bug.