Bug 237966 - Printout is turned 90 degrees on the paper
Printout is turned 90 degrees on the paper
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-26 08:18 EDT by Klaus Munsteiner
Modified: 2008-02-11 12:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 12:22:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File .lpoptions with entry for "Landscape" (329 bytes, application/text)
2007-04-26 08:18 EDT, Klaus Munsteiner
no flags Details

  None (edit)
Description Klaus Munsteiner 2007-04-26 08:18:57 EDT
Description of problem:
Printout is turned 90 degrees on the paper, if in a KDE application the print
orientation is set to "Landscape".

The error occurs in FC5 and FC6.

Version-Release number of selected component (if applicable):
Firefox 1.5.0.10

Steps to Reproduce:
1. Change the print format to landscape:
   You can do it in Konqueror, select:
   Location --> Print --> Properties --> Tab General --> Select: Orientation
Landscape --> Save
  
Actual results:
2. The file /home/<user>/.lpoptions is modified.
3. The printer in the file gets an additional entry: orientation-requested=4
4. This entry turns the paper to landscape. Firefox doesn't know it and makes an
internal additional turn of 90 degrees for the paper and the print. The result
is, the printout is turned 90 degrees on the paper.

Additional info:
5. Firefox must have a "Portrait" for base paper format.

The file / program must be modified, that entry "orientation-requested=4" in the
 file /home/<user>/.lpoptions isn't valid for firefox.
Comment 1 Klaus Munsteiner 2007-04-26 08:18:57 EDT
Created attachment 153498 [details]
File .lpoptions with entry for "Landscape"
Comment 2 Klaus Munsteiner 2007-04-26 08:26:45 EDT
The file .lpoptions with oriantation "Landscape":

Dest HP_DJ895cxi scp-fc5=true
Default HP_LJ4000 Duplex=None kde-margin-bottom=0 kde-margin-left=0
kde-margin-right=0 kde-margin-top=0 orientation-requested=4
Special Advanced%20Faxing%20Tool%20(ksendfax)
Special Mail%20PDF%20File
Special Print%20to%20File%20(PDF)
Special Print%20to%20File%20(PostScript)
Special Send%20to%20Fax
-------------------------------------------------------------------------------

The file .lpoptions with oriantation "Portrait":

Dest HP_DJ895cxi scp-fc5=true
Default HP_LJ4000 Duplex=None kde-margin-bottom=0 kde-margin-left=0
kde-margin-right=0 kde-margin-top=0
Special Advanced%20Faxing%20Tool%20(ksendfax)
Special Mail%20PDF%20File
Special Print%20to%20File%20(PDF)
Special Print%20to%20File%20(PostScript)
Special Send%20to%20Fax
Comment 3 Matěj Cepl 2007-12-10 04:24:55 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 4 Klaus Munsteiner 2007-12-21 07:47:14 EST
I tested it with Fedora Core 7 and the fault is the same.

In FC7 the configuraton file has been moved (renamed)  
from /home/<user>/.lpoptions to /etc/cups/printers.conf

The entry   Option orientation-requested 3    is for portrait and
            Option orientation-requested 4    is for landscape.

In the next days I will install Fedora 8 and test it. I will write the result.

Do you open (copy) a new report for FC7?
Comment 5 Martin Stransky 2007-12-21 08:03:17 EST
no, you don't need that, moved to F7.
Comment 6 Matěj Cepl 2007-12-21 08:46:52 EST
I will still keep NEEDINFO, so we don't forget that you are supposed to add your
F8 report.
Comment 7 Klaus Munsteiner 2008-01-04 15:01:12 EST
I installed F8 and tested it. The fault is different to FC7:

The normal operation for a normal user is OK. If I change the printer settings
in Konqueror everything is fine. There is nothing written into the file
/etc/cups/printers.conf

The fault like descripted is fixed, but there is an other problem:

In /etc/cups/printers.conf only root has rw rights now. This file will be
changed by administation only. Administration --> Printers --> <select a
printer> --> LastTab: Orderoptions --> Select: Orientation
Landscape --> Save

I hope the labels are translated correctly, as my desktop isn't in English.

Root has changed the orientation to landscape:
Option orientation-requested 4
No user can read the configuration file and the print output of all applications
you cann't read.

Why can only root read the configuration? I think other programs use the
configuration information, too.
Comment 9 Tim Waugh 2008-02-11 12:22:13 EST
The permissions on /etc/cups/printers.conf are correct.  They should be 600.

Note You need to log in before you can comment on or make changes to this bug.