This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 238036 - dhclient-script: invalid paths in manpage
dhclient-script: invalid paths in manpage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-26 12:37 EDT by Tomas Hoger
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-26 15:03:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dhclient-script manpage *-hooks files path fix (838 bytes, patch)
2007-04-26 12:37 EDT, Tomas Hoger
no flags Details | Diff

  None (edit)
Description Tomas Hoger 2007-04-26 12:37:36 EDT
Description of problem:

Man page dhclient-script.8 list incorrect path to per-interface up/down hook
scripts.  Man page says:

/etc/dhclient-up-${IF}-hooks
/etc/dhclient-down-${IF}-hooks

While script uses:

    if [ -x /etc/dhclient-${interface}-up-hooks ]; then
    . /etc/dhclient-${interface}-up-hooks;

and 

    if [ -x /etc/dhclient-${interface}-down-hooks ]; then
    . /etc/dhclient-${interface}-down-hooks;


Version-Release number of selected component (if applicable):

dhclient-3.0.5-4.fc6
dhclient-3.0.5-32.fc7

Additional info:

See attached patch.
Comment 1 Tomas Hoger 2007-04-26 12:37:36 EDT
Created attachment 153529 [details]
dhclient-script manpage *-hooks files path fix
Comment 2 David Cantrell 2007-04-26 15:03:09 EDT
I've reassigned this as a rawhide bug since I don't think it's critical enough
for an FC-6 update.  Fixed in rawhide in dhcp-3.0.5-34.
Comment 3 Tomas Hoger 2007-04-27 02:52:42 EDT
Thanks David!  I have no problem with not having it in FC6, just wanted to make
sure it will get fixed.

Note You need to log in before you can comment on or make changes to this bug.