Bug 238072 - mc freezes on fish transfers of files with restrictive modes
mc freezes on fish transfers of files with restrictive modes
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-26 18:11 EDT by Lubomir Kundrak
Modified: 2013-07-02 19:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 15:32:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-04-26 18:11:23 EDT
Description of problem:

Fish transfers freeze when user attempts to copy a file that is not
readable for him.

Version-Release number of selected component (if applicable):

mc-4.6.1a-35.fc6

How reproducible:

Not tried to.

Steps to Reproduce:
(I describe my particular case. Might not apply for other modes/ownership)
1. Create a file owned by root with mode 600
2. Try to transfer it as an ordinary unprivileged user
  
Actual results:

mc freezes after writing a small portion of bogus data to the target file.

Expected results:

And user would have been warned.

Additional info:

Not tried to reproduce. Tell me if you are unable to.
Comment 3 Lubomir Kundrak 2007-09-21 05:20:51 EDT
Ping on this. Additionaly, sshfs support in mc seems to need some more testing,
it breaks in nearly any nonstandard situation, weird file names (escaping
issues), etc., if i remember correctly.
Comment 4 Bug Zapper 2008-04-04 03:07:15 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 5 Bug Zapper 2008-05-06 15:32:34 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.