Bug 238122 - Remove region key binding doesn't work any more
Summary: Remove region key binding doesn't work any more
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: screen (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On: 157821
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-27 10:33 UTC by Oliver Falk
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 10:23:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Oliver Falk 2007-04-27 10:33:36 UTC
Since someone changed bind X to lockscreen, the option to remove a region, which
defaults to bind X was removed. I would suggest to use bind x now or revert it
back to the old behavior.

Comment 1 Jens Petersen 2007-04-30 23:35:35 UTC
Fair point.  The change was made in bug 157821 to make it harder to lock screen
by accidental.

But perhaps it would be better then to revert to binding x to lockscreen instead
of X but not Ctrl-x.  Hopefully that would still be kinder to emacs users. 
Otherwise some other way to prevent accidental locking could be added to screen
IMHO, like a [y/n] prompt.

Comment 2 Oliver Falk 2007-05-02 08:08:30 UTC
C-A C-L, what about this. The uppercase L is still free, I believe...

Comment 3 Jens Petersen 2007-05-02 23:30:28 UTC
That sounds fine too. :)

Comment 4 Marcela Mašláňová 2007-05-10 13:14:37 UTC
I prefer removing changes for compatibility with upstream and other distros to
changing it. Wouldn't be ok to make a note in man page and in configuration file
for emacs users?

Comment 5 Oliver Falk 2007-05-10 13:40:40 UTC
I don't mind. I just want a remove option :-)

Comment 6 Jens Petersen 2007-05-10 14:08:38 UTC
(In reply to comment #4)
> I prefer removing changes for compatibility with upstream and other distros to
> changing it. Wouldn't be ok to make a note in man page and in configuration file
> for emacs users?

The problem is the upstream default binding is really pretty easy to trigger
accidently and then (if a passwd is not already set?) it is impossible
to return to the screen session.  Or am I missing something?  If I knew
how to unlock screen after that it would not bother me much.

Comment 7 Oliver Falk 2007-05-10 15:48:53 UTC
If no passwd is set, shouln't enter do it? Possibly not, I'm not sure. Would
need to test. Yes, it's easy to trigger. But at the moment, people who are used
to the old key bindings, will trigger it more often (like me)...

Hm. I think the number of users without passwd set using screen is very small!?
And if, the user must have logged in via ssh and public key or via console or
telnet or whatever. He can still open another session and set a passwd or even
kill the screen...

Comment 8 Jens Petersen 2007-05-11 07:52:42 UTC
(In reply to comment #7)
> If no passwd is set, shouln't enter do it?

Doh - now I understand - the password just means the system password!
I vaguely seem to remember in some past having to set a passwd when locking
but maybe that was using another program to do that?  That was confusing me. :)

> Yes, it's easy to trigger. But at the moment, people who are used
> to the old key bindings, will trigger it more often (like me)...

Yup.  Well now that I know what the passwd is I am less worried about.
So it is ok for me just to revert to the old bindings.

> He can still open another session and set a passwd or even
> kill the screen...

Maybe it would be enough to just document that it is the system passwd
or maybe it is obvious to everyone else?

Comment 9 Oliver Falk 2007-05-11 08:08:29 UTC
Maybe there was a screen version that wasn't using the system pw? I don't know.

I don't think we need to document with pw is meant.

Just revert and add this bug# to the cl. :-)

Comment 10 Marcela Mašláňová 2007-05-15 11:03:38 UTC
Hello,
I'll revert it. 

comment#8 
The password is asked with name of user, so it's the same like locking computer. 
If you want different binding, you can redefine it in /etc/screenrc.
Regards,
Marcela

Comment 11 Oliver Falk 2007-05-15 11:52:53 UTC
Great!

Comment 12 Oliver Falk 2007-05-29 07:33:11 UTC
this hasn't been done already, has it!?

Comment 13 Marcela Mašláňová 2007-07-02 11:29:39 UTC
It was fixed in devel.

Comment 14 Oliver Falk 2007-07-02 11:35:49 UTC
WorksForMe(tm).


Note You need to log in before you can comment on or make changes to this bug.