Bug 238125 - LSB init function to print warnings has the wrong name
LSB init function to print warnings has the wrong name
Status: CLOSED DUPLICATE of bug 240916
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-lsb (Show other bugs)
5.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-27 07:51 EDT by Joachim Worringen
Modified: 2014-03-25 20:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-17 21:43:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Worringen 2007-04-27 07:51:25 EDT
Description of problem:
/lib/lsb/init-functions defines a few LSB-compliant init script functions. Here,
the function to print a log warning has the wrong name "log_warning_message".
The correct name is "log_warning_msg" (as the other functions have and as it is
defined in the LSB standard).

The fix is trivial: just rename this function.

Version-Release number of selected component (if applicable):
n/a

How reproducible:
Use log_warning_msg() in any LSB-style init script.
 
Actual results:
Error/Warning message about function not defined

Expected results:
Proper warning message (as in RHEL 4)

Additional info:
- LSB spec for this at
http://refspecs.freestandards.org/LSB_3.1.0/LSB-Core-generic/LSB-Core-generic/iniscrptfunc.html

- Filed also under http://bugs.centos.org/view.php?id=1951
Comment 1 Bill Nottingham 2007-05-01 00:48:50 EDT
/lib/lsb/init-functions is provided by redhat-lsb - reassigning.
Comment 3 RHEL Product and Program Management 2007-05-01 20:43:40 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Lawrence Lim 2007-06-17 21:43:46 EDT

*** This bug has been marked as a duplicate of 240916 ***

Note You need to log in before you can comment on or make changes to this bug.