Bug 238137 - SELinux blocks logwatch from access to clamav logs
Summary: SELinux blocks logwatch from access to clamav logs
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-27 13:09 UTC by Martin Poole
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0544
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 16:39:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against serefpolicy-2.4.6 to give logwatch access to clamav logs (1.15 KB, patch)
2007-04-27 13:09 UTC, Martin Poole
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0544 normal SHIPPED_LIVE selinux-policy bug fix update 2007-11-08 14:16:49 UTC

Description Martin Poole 2007-04-27 13:09:49 UTC
Description of problem:

SELinux is preventing 0logwatch (logwatch_t) 'search' to clamav (clamd_var_log_t)


Version-Release number of selected component (if applicable):

2.4.6-30.el5

How reproducible:

Always

Steps to Reproduce:
1. logwatch --service clamav --detail 5
2.
3.
  
Actual results:

avc: denied { search } for comm="0logwatch" dev=dm-1 egid=0 euid=0
exe="/usr/bin/perl" exit=-13 fsgid=0 fsuid=0 gid=0 items=0 name="clamav"
pid=5583 scontext=system_u:system_r:logwatch_t:s0-s0:c0.c1023 sgid=0
subj=system_u:system_r:logwatch_t:s0-s0:c0.c1023 suid=0 tclass=dir
tcontext=system_u:object_r:clamd_var_log_t:s0 tty=(none) uid=0

Expected results:

no error logs

Additional info:

Comment 1 Martin Poole 2007-04-27 13:09:50 UTC
Created attachment 153619 [details]
patch against serefpolicy-2.4.6 to give logwatch access to clamav logs

Comment 2 Daniel Walsh 2007-04-27 16:06:12 UTC
Fixed in selinux-policy-2.4.6-68

Comment 3 RHEL Product and Program Management 2007-06-04 20:44:23 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 7 Eduard Benes 2007-08-23 14:38:24 UTC
Martin, I'm not able to reproduce this bug. Could you please try the new 
policy available at the link below and reply whether the new packages solve 
your problem. Thank you.

http://nest.test.redhat.com/qa/scratch/ebenes/selinux-policy/83.el5/

Comment 9 errata-xmlrpc 2007-11-07 16:39:22 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0544.html



Note You need to log in before you can comment on or make changes to this bug.