Bug 238179 - cache.log is rapidly beeing filled with error message
Summary: cache.log is rapidly beeing filled with error message
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: squid   
(Show other bugs)
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Martin Bacovsky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-27 18:17 UTC by Boris Folgmann
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version: squid-2.5.STABLE14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 15:03:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Boris Folgmann 2007-04-27 18:17:33 UTC
Description of problem:
/var/log/squid/cache.log is rapidly beeing filled with error messages

Version-Release number of selected component (if applicable):
squid-2.5.STABLE6-3.4E.12

squid seems to be very picky on replies of certain webservers. This error
message is permanently logged since days:

2007/04/23 09:28:20| ctx: enter level  0:
'http://www.spreadshirt.net/shop.php?sid=198137&op=rss_articles'
2007/04/23 09:28:20| WARNING: found whitespace in HTTP header name {Content type: }
2007/04/23 09:28:20| ctx: exit level  0
2007/04/23 09:28:20| WARNING: found whitespace in HTTP header name {Content type: }
2007/04/23 09:28:20| ctx: enter level  0:
'http://www.spreadshirt.net/shop.php?sid=198137&op=rss_articles'
2007/04/23 09:28:20| WARNING: found whitespace in HTTP header name {Content type: }
2007/04/23 09:28:20| ctx: exit level  0
2007/04/23 09:28:20| WARNING: found whitespace in HTTP header name {Content type: }
2007/04/23 09:29:21| ctx: enter level  0:
'http://www.spreadshirt.net/shop.php?sid=198137&op=rss_articles'
2007/04/23 09:29:21| WARNING: found whitespace in HTTP header name {Content type: }
2007/04/23 09:29:21| ctx: exit level  0
2007/04/23 09:29:21| WARNING: found whitespace in HTTP header name {Content type: }
2007/04/23 09:29:22| ctx: enter level  0:
'http://www.spreadshirt.net/shop.php?sid=198137&op=rss_articles'
2007/04/23 09:29:22| WARNING: found whitespace in HTTP header name {Content type: }
2007/04/23 09:29:22| ctx: exit level  0
2007/04/23 09:29:22| WARNING: found whitespace in HTTP header name {Content type: }
2007/04/23 09:30:23| ctx: enter level  0:
'http://www.spreadshirt.net/shop.php?sid=198137&op=rss_articles'
2007/04/23 09:30:23| WARNING: found whitespace in HTTP header name {Content type: }
2007/04/23 09:30:23| ctx: exit level  0

[...]

2007/04/27 20:15:47| WARNING: found whitespace in HTTP header name {Content type: }
2007/04/27 20:15:48| ctx: enter level  0:
'http://www.spreadshirt.net/shop.php?sid=198137&op=rss_articles'
2007/04/27 20:15:48| WARNING: found whitespace in HTTP header name {Content type: }
2007/04/27 20:15:48| ctx: exit level  0
2007/04/27 20:15:48| WARNING: found whitespace in HTTP header name {Content type: }

Comment 1 Martin Bacovsky 2007-05-31 13:19:19 UTC
Please, let me know if this error still occuring in updated squid
(squid-2.5.STABLE14)? After stable8 the behaviour when getting HTTP header with
whitespace had changed.

Comment 2 Boris Folgmann 2007-06-22 10:54:33 UTC
No, it seems to be fixed. Feel free to close the bug. Tnx.


Note You need to log in before you can comment on or make changes to this bug.