Bug 238187 - RFE: Please add support for the RTL8111/8168B PCI Express network cards to the RHES5 kernel
RFE: Please add support for the RTL8111/8168B PCI Express network cards to th...
Status: CLOSED DUPLICATE of bug 247142
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivan Vecera
Martin Jenner
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2007-04-27 15:40 EDT by Bernd Bartmann
Modified: 2008-02-26 11:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-26 11:37:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2007-04-27 15:40:44 EDT
Description of problem:
The kernel that comes with RHES5 does not yet have support for the RTL8111/8168B
PCI Express network card. The card is now supported in FC7T4 and so it should be
in RHES5 as more and more mainboards have this on-board by default.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Milan Kerslager 2007-08-22 07:01:55 EDT
The kernel kernel-2.6.18-36.el5 from Beta channel for RHEL5 does not support
"RTL8111/8168B PCI Express Gigabit Ethernet controller" yet even this is widely
used chip.
Comment 2 Andy Gospodarek 2007-09-12 13:45:51 EDT
Can either of your post the output of lspci and lspci -n so I can see the
specific PCI id's that are not working.  Thanks!
Comment 3 Andy Gospodarek 2007-09-12 13:48:48 EDT
Ivan has some patches for rhel5 that should hopefully resolve this, but the
output from either reporter would be nice so we can be sure.
Comment 4 Milan Kerslager 2007-09-13 00:25:34 EDT
On ASUS M2A-VM board (lspci and lspci -n):

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
Express Gigabit Ethernet controller (rev 01)

03:00.0 0200: 10ec:8168 (rev 01)
Comment 5 Ivan Vecera 2007-09-17 11:01:24 EDT
Hi, this bug seems to be duplicate of bug #247142. I built a test kernel
packages so could you please test it on your hardware and report a test result?

-- Ivan
Comment 6 Milan Kerslager 2007-09-18 01:54:22 EDT
Yes I'm able to see the interface. I'm not able to test it yet. I'll try switch
cables tomorow.

r8169 Gigabit Ethernet driver 2.2LK-NAPI loaded
ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 19 (level, low) -> IRQ 209
PCI: Setting latency timer of device 0000:02:00.0 to 64
eth1: RTL8168b/8111b at 0xffffc2000006a000, 00:1a:92:6f:e2:b2, IRQ 209

I'm not able to view bug #247142. Is the problem only in PCI's id?
Comment 7 Ivan Vecera 2007-09-18 05:05:04 EDT
No, for bug #247142 and also for bug #248534 was backported r8169 driver from
Now I'm waiting for your todays test and if will it be OK then I mark this bug
as duplicate.

-- Ivan
Comment 8 Milan Kerslager 2007-09-19 13:32:38 EDT
It seems to work without any problem since I plugged the wire. Thank you.
Could do you upload src.rpm package too?
Comment 9 Ivan Vecera 2007-09-20 02:51:47 EDT
OK, you can now download the srpm from the same place.

Comment 10 Ivan Vecera 2007-09-20 02:53:13 EDT

*** This bug has been marked as a duplicate of 247142 ***
Comment 11 Milan Kerslager 2008-02-12 07:24:42 EST
As there is no public access to bug #247142, I have a question:
Is there any progress with Realtek Gbps NICs?
Comment 12 Ivan Vecera 2008-02-26 11:37:55 EST
Yes, the patch was accepted and will be integrated in the RHEL 5.2 release.

*** This bug has been marked as a duplicate of 247142 ***

Note You need to log in before you can comment on or make changes to this bug.