Bug 238227 - Nautilus crash at login "Nautilus can't be used now, due to an unexpected error" (bonobo error)
Summary: Nautilus crash at login "Nautilus can't be used now, due to an unexpected err...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
(Show other bugs)
Version: 10
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact:
URL:
Whiteboard:
Keywords:
: 462235 471366 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-28 02:11 UTC by Rahul Sundaram
Modified: 2015-03-03 22:31 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-18 17:37:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nautilus bonobo crash error on login (38.87 KB, image/png)
2007-04-30 11:37 UTC, Rahul Sundaram
no flags Details
.xsession-errors file showing the error (2.01 KB, application/octet-stream)
2007-06-14 19:43 UTC, Mikkel Lauritsen
no flags Details

Description Rahul Sundaram 2007-04-28 02:11:13 UTC
Description of problem:


When logging into the GNOME based i386 Fedora 7 test 4 live cd nautilus
sometimes crashes with a vague bonobo error and the desktop is black. Running
nautilus again usually fixes this. This also happened on the test 2 live cd
release. 

Version-Release number of selected component (if applicable):

nautilus-2.18.1-2.fc7

How reproducible:

Rarely


Steps to Reproduce:

1. Login into GNOME

  

Actual results:

Sometimes nautilus crashes and desktop is blank. no panel etc. 

Expected results:

Fully functional desktop. No crashes. 

Additional info:

Sorry. I did not note the specific bonobo error and the crash is not very
reproducible. I will post the error or screenshot if it happens again.

Comment 1 Rahul Sundaram 2007-04-30 11:37:47 UTC
Created attachment 153786 [details]
nautilus bonobo crash error on login

Comment 2 Alexander Larsson 2007-05-03 14:20:44 UTC
The error means: we registered the shell with
bonobo_activation_register_active_server, which succeeded but then 
 bonobo_activation_activate_from_id(SHELL_IID,
Bonobo_ACTIVATION_FLAG_EXISTING_ONLY, NULL, NULL) fails.

This really shouldn't happen... Maybe its is a race when multiple nautilus
instances are run...

Comment 3 Rahul Sundaram 2007-05-03 14:27:18 UTC
I am just doing a regular login and it crashes every single time for me now. Not
sure why multiple nautilus instances would be launched. Is there anything that I
do to help you fix this issue?

Comment 4 Mikkel Lauritsen 2007-06-14 19:42:43 UTC
I have experienced the exact same problem on F7 final, with all updates as of
June 14 installed. I use user switching, but so far the Nautilus problem has
only shown when no more than one user has been logged in at the same time.


Comment 5 Mikkel Lauritsen 2007-06-14 19:43:29 UTC
Created attachment 157036 [details]
.xsession-errors file showing the error

Comment 6 Bug Zapper 2008-05-14 02:49:14 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Bojan Smojver 2008-11-21 06:20:58 UTC
This should be re-based to 10. I can see this in (at least) a VNC session.

Comment 8 Bojan Smojver 2008-12-02 07:45:42 UTC
Workaround, from the command line:

nautilus --no-default-window --oaf-ior-fd=<the one you see for bonobo-activation-server>

Comment 9 Davide Repetto 2008-12-08 21:20:24 UTC
Can you elaborate on the meaning of "<the one you see for bonobo-activation-server>"

Anyway this bug happens even more often in F10. I'm noticing it on almost any machine I upgraded (about 15 up to now).

Comment 10 Stephen Warren 2008-12-08 21:40:28 UTC
Updating version to 10, to avoid this bug getting auto-closed once F9 is no longer maintained, since people are seeing the issue in F10 too.

Comment 11 Stephen Warren 2008-12-08 21:41:25 UTC
*** Bug 462235 has been marked as a duplicate of this bug. ***

Comment 12 Stephen Warren 2008-12-08 21:43:02 UTC
Editing the bug title, so people can find this bug by searching for the error message.

Comment 13 Stephen Warren 2008-12-08 21:46:03 UTC
Copying CC list from dup'd bug.

Comment 14 Bojan Smojver 2008-12-09 07:20:40 UTC
Regarding comment #10, run:

ps -ef | grep bonobo-activation-server

You'll get something like:

/usr/libexec/bonobo-activation-server --ac-activate --ior-output-fd=17

Seventeen is the magic number there...

Comment 15 Mike Iglesias 2008-12-15 17:59:55 UTC
I tried renaming the .nautilus directory to see if that would fix this error and it didn't.  When I moved all the gnome directories and the .nautilus directory out of the way, logged out, and logged in again this error went away.

Comment 16 Bojan Smojver 2008-12-22 07:00:57 UTC
Hmm... Just restarted my vncserver and when the session started, no error. Also, gnome-settings-daemon started all by itself. Has something been fixed?

Comment 17 aanderson 2009-01-25 21:16:50 UTC
I had this same error to fix it I opened a terminal window logged in as root
su -
then i reinstalled the gnome desktop package
yum reinstall gnome-desktop

Comment 18 Christopher Beland 2009-07-31 18:25:03 UTC
Is anyone still seeing this in Fedora 10 with the latest updates, or Fedora 11?  I saw this in Fedora 9, but I am not experiencing it in Fedora 11.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 19 Christopher Beland 2009-07-31 18:26:24 UTC
*** Bug 471366 has been marked as a duplicate of this bug. ***

Comment 20 Tomáš Bžatek 2009-08-03 12:46:16 UTC
Nautilus in F11 doesn't use bonobo anymore for startup, we use libunique now. Such error messages might be result of some bonobo issue, outside nautilus package.

Comment 21 Rahul Sundaram 2009-08-04 07:13:04 UTC
I don't understand the needinfo here. What information do you need exactly?

Comment 22 Tomáš Bžatek 2009-08-04 12:04:08 UTC
(In reply to comment #21)
> I don't understand the needinfo here. What information do you need exactly?  
The needinfo was just re-set from comment #18 - "Is anyone still seeing this in Fedora 10 with the latest updates?"

Comment 23 Rahul Sundaram 2009-08-04 12:09:12 UTC
This bug was reported by me more than 2 and a half years back and was never responded to nor was it fixed then. I don't see a point in trying to respond to it now. The release is EOL'ed. Just close it and move on.

Comment 24 Bug Zapper 2009-11-18 08:11:41 UTC
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.