Bug 238252 - include sane module
include sane module
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-imaging (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: José Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 06:11 EDT by Nils Philippsen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 03:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix incompatible pointer type warning (402 bytes, patch)
2007-04-28 06:11 EDT, Nils Philippsen
no flags Details | Diff

  None (edit)
Description Nils Philippsen 2007-04-28 06:11:55 EDT
Description of problem:
Python Imaging contains a module to access scanners via SANE. This is currently
not built and distributed but only included in the -devel documentation, i.e.
you have to build it yourself if you want to use it. Which is bad if at some
point you want to distribute anything using that module ;-).

It would be good if this module were built and distributed, possibly in a
subpackage. Speaking about subpackages, it would be good if the Tk-depending
modules were separate from the main module as well so that you don't suck in the
whole Tcl/Tk stack if you weant to use the Imaging module, but use another
toolkit for display. Shout if you want a separate bugzilla entry for that ;-).

Version-Release number of selected component (if applicable):
python-imaging-1.1.6-1.fc6

I'll attach a small patch that fixes an incompatible pointer type warning.

If you wish, I'll work on the necessary spec file changes, just tell me in that
case.
Comment 1 Nils Philippsen 2007-04-28 06:11:55 EDT
Created attachment 153699 [details]
patch to fix incompatible pointer type warning
Comment 2 José Matos 2007-04-28 07:33:23 EDT
(In reply to comment #0)
[All good stuff]
> Version-Release number of selected component (if applicable):
> python-imaging-1.1.6-1.fc6
> 
> I'll attach a small patch that fixes an incompatible pointer type warning.
> 
> If you wish, I'll work on the necessary spec file changes, just tell me in 
that
> case.

Hi Nils,
  All the issues you mentioned above have been in my mind for some time. :-)
I was just waiting for a nag message to move my ass and do something about it.

  So if you don't mind you could work on them and commit the appropriate 
changes, I am a bit busy at moment or else I would do them myself. I do not 
want to stop working on python-imaging (that I use) but if you are motivated 
by these issues I don't want to stop you from implementing them. I hope you 
understand the reasons. :-)

  Tell me if there any acl changes that I need to do for this to be possible.
Comment 3 Nils Philippsen 2007-04-29 17:05:14 EDT
committed to CVS:

* Sun Apr 29 2007 Nils Philippsen <nphilipp@redhat.com> - 1.1.6-3
- add sane subpackage, split off tk subpackage (#238252)
- add sane-types patch
- use -b for patches to save original files
- correct groups

Do you want to build or shall I?
Comment 4 José Matos 2007-04-29 17:32:53 EDT
Please, go ahead.

One note, in the naming of the tk interface I had thought about using tkinter 
instead of just tk, on the other hand there is neither a rule or guideline nor 
other similar examples so I trust your choice here. :-)
Comment 5 Nils Philippsen 2007-04-30 03:56:26 EDT
At least it makes a short name ;-). I've kicked off the builds for FC-6 and
devel with the aforementioned changes.

Note You need to log in before you can comment on or make changes to this bug.