Bug 238265 - RFE: dont install sound card software on pc without sound
Summary: RFE: dont install sound card software on pc without sound
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-28 14:46 UTC by David Timms
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 19:10:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Timms 2007-04-28 14:46:31 UTC
Description of problem:
For a server or PC without sound {or working sound eg neomagic256}, there is no
need to install sound apps. Some apps crash when they try to access non-existent hw.

Version-Release number of selected component (if applicable):
f7t4

How reproducible:
any machine without soundcard capabilities, eg Dell Poweredge 2650 etc.

Steps to Reproduce:
1. install f7 or any release since about FC3/4
  
Actual results:
Apps like system-config-soundcard, gnome-applet {volume control},
gnome-volume-control, cd player, totem, gnome-audio, get installed.

Expected results:
none of the above should be installed. Additionally, it should be possible to
play a media clip without an audio card {sans audio}.

Additional info:
This might be wanted for minimal gnome gui installs - eg servers. The less
things that are installed should reduce the risk of something going wrong.
Also would avoid the desktop login applet crashes for machines that don't have
sound or have unsupported sound.

Another alternative to avoid these crashes is to create/config a null driver,
that receives sound streams but just dumps them.

At the moment package division means that you can't remove most of these items,
even if you want to. 

Additionally, the gnome volume-spplet icon is installed by default into new user
accounts. This then leads to effort to remove the icon from each user.

Comment 1 David Timms 2007-04-28 14:49:33 UTC
similar to bug 161029. which says it is resolved; however that bug is still an
issue in fc6.

Comment 2 Jeremy Katz 2007-04-30 19:10:14 UTC
Some of these are parts of packages and can't be just split out (eg, the volume
control applet is just part of gnome-applets).  These applications really
_shouldn't_ crash if there's no sound card; if they do, that's the real bug here.

Anaconda doing weird one-offs based on hardware is pretty much entirely
unmaintainable


Note You need to log in before you can comment on or make changes to this bug.