Bug 238293 - blt package missing shared libraries and needs a -devel package for headers
blt package missing shared libraries and needs a -devel package for headers
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: blt (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jean-Luc Fontaine
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 18:47 EDT by Eric Hopper
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 15:33:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patches .spec file to installed shared libraries and adds a -devel package for includes (1.97 KB, patch)
2007-04-29 20:59 EDT, Eric Hopper
no flags Details | Diff
Updated, no -devel and installs the .so and .h files. (1.84 KB, patch)
2007-04-30 06:16 EDT, Eric Hopper
no flags Details | Diff
Updated again to work on 64-bit (2.37 KB, patch)
2007-04-30 07:03 EDT, Eric Hopper
no flags Details | Diff

  None (edit)
Description Eric Hopper 2007-04-28 18:47:02 EDT
This problem makes it impossible to compile some C and C++ packages that use BLT
widgets.
Comment 1 Eric Hopper 2007-04-28 19:49:34 EDT
After further investigation, here is a list of all the files that need to be
installed that aren't:

usr/lib/libBLT24.so
usr/lib/libBLTlite24.so
usr/include/blt.h
usr/include/bltHash.h
usr/include/bltPool.h
usr/include/bltVector.h

The .so files need to be installed as part of the main blt package, and the .h
files should be in a -devel package.

IMHO, the bltwish file should be installed too.
Comment 2 Eric Hopper 2007-04-29 20:59:13 EDT
Created attachment 153752 [details]
Patches .spec file to installed shared libraries and adds a -devel package for includes

This patch for the .spec file should fix this bug.
Comment 3 Jean-Luc Fontaine 2007-04-30 02:34:05 EDT
Unfortunately, I do not have the resources to support a devel package.
Comment 4 Eric Hopper 2007-04-30 05:37:37 EDT
The package as it stands is totally non-functional as the .so files do not get
installed.  The -devel package would be nice to have, but the change to install
.so files is an absolute must for the package to be even remotely usable by anybody.
Comment 5 Jean-Luc Fontaine 2007-04-30 05:56:48 EDT
You must be joking:
# rpm -ql blt | fgrep .so
/usr/lib64/blt2.4/libBLT24.so
/usr/lib64/blt2.4/libBLTlite24.so

Comment 6 Eric Hopper 2007-04-30 06:00:33 EDT
If I were joking I wouldn't have filed the bug report.

# uname -a
Linux bats.omnifarious.org 2.6.20-1.2944.fc6 #1 SMP Tue Apr 10 17:46:00 EDT 2007
x86_64 x86_64 x86_64 GNU/Linux
# rpm -q blt
blt-2.4-14.z.fc6
# rpm -lq blt
/usr/lib/blt2.4
/usr/lib/blt2.4/bltCanvEps.pro
/usr/lib/blt2.4/bltGraph.pro
/usr/lib/blt2.4/dd_protocols
/usr/lib/blt2.4/dd_protocols/dd-color.tcl
/usr/lib/blt2.4/dd_protocols/dd-file.tcl
/usr/lib/blt2.4/dd_protocols/dd-number.tcl
/usr/lib/blt2.4/dd_protocols/dd-text.tcl
/usr/lib/blt2.4/dd_protocols/tclIndex
/usr/lib/blt2.4/dnd.tcl
/usr/lib/blt2.4/dragdrop.tcl
/usr/lib/blt2.4/graph.tcl
/usr/lib/blt2.4/hierbox.tcl
/usr/lib/blt2.4/hiertable.tcl
/usr/lib/blt2.4/libBLT24.so
/usr/lib/blt2.4/libBLTlite24.so
/usr/lib/blt2.4/pkgIndex.tcl
/usr/lib/blt2.4/tabnotebook.tcl
/usr/lib/blt2.4/tabset.tcl
/usr/lib/blt2.4/tclIndex
/usr/lib/blt2.4/treeview.tcl
/usr/lib/blt2.4/treeview.xbm
/usr/lib/blt2.4/treeview_m.xbm
/usr/share/doc/blt-2.4
/usr/share/doc/blt-2.4/INSTALL
/usr/share/doc/blt-2.4/PROBLEMS
/usr/share/doc/blt-2.4/README
/usr/share/doc/blt-2.4/html
/usr/share/doc/blt-2.4/html/BLT.html
/usr/share/doc/blt-2.4/html/barchart.html
/usr/share/doc/blt-2.4/html/beep.html
/usr/share/doc/blt-2.4/html/bgexec.html
/usr/share/doc/blt-2.4/html/bitmap.html
/usr/share/doc/blt-2.4/html/bltdebug.html
/usr/share/doc/blt-2.4/html/busy.html
/usr/share/doc/blt-2.4/html/container.html
/usr/share/doc/blt-2.4/html/cutbuffer.html
/usr/share/doc/blt-2.4/html/dragdrop.html
/usr/share/doc/blt-2.4/html/eps.html
/usr/share/doc/blt-2.4/html/graph.html
/usr/share/doc/blt-2.4/html/hierbox.html
/usr/share/doc/blt-2.4/html/hiertable.html
/usr/share/doc/blt-2.4/html/htext.html
/usr/share/doc/blt-2.4/html/spline.html
/usr/share/doc/blt-2.4/html/stripchart.html
/usr/share/doc/blt-2.4/html/table.html
/usr/share/doc/blt-2.4/html/tabset.html
/usr/share/doc/blt-2.4/html/tile.html
/usr/share/doc/blt-2.4/html/tree.html
/usr/share/doc/blt-2.4/html/treeview.html
/usr/share/doc/blt-2.4/html/vector.html
/usr/share/doc/blt-2.4/html/watch.html
/usr/share/doc/blt-2.4/html/winop.html
Comment 7 Eric Hopper 2007-04-30 06:02:19 EDT
And the proper thing to do, if you don't want to support an extra -devel package
is to make sure the headers get installed with the standard package.
Comment 8 Eric Hopper 2007-04-30 06:16:56 EDT
Created attachment 153779 [details]
Updated, no -devel and installs the .so and .h files.

This patch will update the 2.4-14z .spec file to the 2.4z-16 .spec file that
solves all the problems mentioned in this bug report.
Comment 9 Eric Hopper 2007-04-30 07:03:25 EDT
Created attachment 153780 [details]
Updated again to work on 64-bit

The previous patch fails on a 64-bit box because it looks for tclConfig.sh and
tkConfig.sh in /usr/lib64 and they are installed in /usr/lib.  This patch looks
for them in %{_prefix}/lib which is where the tcl.spec and tk.spec files
install them.
Comment 10 Eric Hopper 2007-04-30 07:18:29 EDT
(In reply to comment #6)
> If I were joking I wouldn't have filed the bug report.
> 
> # uname -a
> Linux bats.omnifarious.org 2.6.20-1.2944.fc6 #1 SMP Tue Apr 10 17:46:00 EDT 2007
> x86_64 x86_64 x86_64 GNU/Linux

Err, hee...  I ran uname on the wrong system.  :-)

# uname -a
Linux attic.omnifarious.org 2.6.20-1.2944.fc6 #1 SMP Tue Apr 10 18:46:45 EDT
2007 i686 athlon i386 GNU/Linux
Comment 11 Jean-Luc Fontaine 2007-04-30 07:24:37 EDT
>If I were joking I wouldn't have filed the bug report.
># rpm -lq blt
>...
>/usr/lib/blt2.4/libBLT24.so
>/usr/lib/blt2.4/libBLTlite24.so
What is this then?
Comment 12 Eric Hopper 2007-04-30 07:34:38 EDT
Try removing the package and installing it with yum.  Those files won't be there
then I'm sure.
Comment 13 Eric Hopper 2007-04-30 07:38:31 EDT
Also, when you run rpm, do 'rpm -q blt' first so it can be seen exactly which
version you have installed.
Comment 14 Jean-Luc Fontaine 2007-04-30 07:40:15 EDT
>Try removing the package and installing it with yum.  Those files won't be there
then I'm sure.
I did and they are: did you actually witness that behavior? That would be a
major bug with yum/rpm.
Comment 15 Eric Hopper 2007-04-30 07:43:26 EDT
Yes, I did.  That was exactly what I had done to get the output I showed you.

And earlier, I hand-downloaded the .src.rpm packages and compiled them myself
and still have the problem after installing the resulting .rpm.  Can you please
do 'rpm -q package' so that we can compare versions?  Maybe you're somehow
getting a different version than I am.
Comment 16 Jean-Luc Fontaine 2007-04-30 08:20:46 EDT
# rpm -q blt
blt-2.4-14.z.fc6
# rpm -qlp /home/fedora/linux/extras/6/i386/blt-2.4-14.z.fc6.i386.rpm | fgrep .so
/usr/lib/blt2.4/libBLT24.so
/usr/lib/blt2.4/libBLTlite24.so
# ls -l /usr/lib64/blt2.4/
total 1520
-rw-r--r-- 1 root root    2277 Feb  7  2001 bltCanvEps.pro
-rw-r--r-- 1 root root   13139 Sep  4  2002 bltGraph.pro
drwxr-xr-x 2 root root    4096 Nov  2 15:21 dd_protocols
-rw-r--r-- 1 root root    3250 Feb  3  2002 dnd.tcl
-rw-r--r-- 1 root root    2790 Feb  3  2002 dragdrop.tcl
-rw-r--r-- 1 root root   14160 Jun 18  2002 graph.tcl
-rw-r--r-- 1 root root   13607 Feb  3  2002 hierbox.tcl
-rw-r--r-- 1 root root   24690 Feb  3  2002 hiertable.tcl
-rwxr-xr-x 1 root root 1152456 Aug 28  2006 libBLT24.so
-rwxr-xr-x 1 root root  222528 Aug 28  2006 libBLTlite24.so
-rw-r--r-- 1 root root     150 Aug 28  2006 pkgIndex.tcl
-rw-r--r-- 1 root root   10400 May 13  2002 tabnotebook.tcl
-rw-r--r-- 1 root root   10408 May 13  2002 tabset.tcl
-rw-r--r-- 1 root root     653 Feb  7  2002 tclIndex
-rw-r--r-- 1 root root     331 Feb  3  2002 treeview_m.xbm
-rw-r--r-- 1 root root   25453 Aug  6  2002 treeview.tcl
-rw-r--r-- 1 root root     326 Feb  3  2002 treeview.xbm
Comment 17 Eric Hopper 2007-04-30 10:48:40 EDT
# lftp ftp://limestone.uoregon.edu/fedora/
cd ok, cwd=/fedora                                        
lftp limestone.uoregon.edu:/fedora> get extras/6/x86_64/blt-2.4-14.z.fc6.x86_64.rpm 
843862 bytes transferred in 4 seconds (223.9K/s)                                
lftp limestone.uoregon.edu:/fedora> quit
# rpm -qp blt-2.4-14.z.fc6.x86_64.rpm 
blt-2.4-14.z.fc6
# rpm -lqp blt-2.4-14.z.fc6.x86_64.rpm 
/usr/lib64/blt2.4
/usr/lib64/blt2.4/bltCanvEps.pro
/usr/lib64/blt2.4/bltGraph.pro
/usr/lib64/blt2.4/dd_protocols
/usr/lib64/blt2.4/dd_protocols/dd-color.tcl
/usr/lib64/blt2.4/dd_protocols/dd-file.tcl
/usr/lib64/blt2.4/dd_protocols/dd-number.tcl
/usr/lib64/blt2.4/dd_protocols/dd-text.tcl
/usr/lib64/blt2.4/dd_protocols/tclIndex
/usr/lib64/blt2.4/dnd.tcl
/usr/lib64/blt2.4/dragdrop.tcl
/usr/lib64/blt2.4/graph.tcl
/usr/lib64/blt2.4/hierbox.tcl
/usr/lib64/blt2.4/hiertable.tcl
/usr/lib64/blt2.4/libBLT24.so
/usr/lib64/blt2.4/libBLTlite24.so
/usr/lib64/blt2.4/pkgIndex.tcl
/usr/lib64/blt2.4/tabnotebook.tcl
/usr/lib64/blt2.4/tabset.tcl
/usr/lib64/blt2.4/tclIndex
/usr/lib64/blt2.4/treeview.tcl
/usr/lib64/blt2.4/treeview.xbm
/usr/lib64/blt2.4/treeview_m.xbm
/usr/share/doc/blt-2.4
/usr/share/doc/blt-2.4/INSTALL
/usr/share/doc/blt-2.4/PROBLEMS
/usr/share/doc/blt-2.4/README
/usr/share/doc/blt-2.4/html
/usr/share/doc/blt-2.4/html/BLT.html
/usr/share/doc/blt-2.4/html/barchart.html
/usr/share/doc/blt-2.4/html/beep.html
/usr/share/doc/blt-2.4/html/bgexec.html
/usr/share/doc/blt-2.4/html/bitmap.html
/usr/share/doc/blt-2.4/html/bltdebug.html
/usr/share/doc/blt-2.4/html/busy.html
/usr/share/doc/blt-2.4/html/container.html
/usr/share/doc/blt-2.4/html/cutbuffer.html
/usr/share/doc/blt-2.4/html/dragdrop.html
/usr/share/doc/blt-2.4/html/eps.html
/usr/share/doc/blt-2.4/html/graph.html
/usr/share/doc/blt-2.4/html/hierbox.html
/usr/share/doc/blt-2.4/html/hiertable.html
/usr/share/doc/blt-2.4/html/htext.html
/usr/share/doc/blt-2.4/html/spline.html
/usr/share/doc/blt-2.4/html/stripchart.html
/usr/share/doc/blt-2.4/html/table.html
/usr/share/doc/blt-2.4/html/tabset.html
/usr/share/doc/blt-2.4/html/tile.html
/usr/share/doc/blt-2.4/html/tree.html
/usr/share/doc/blt-2.4/html/treeview.html
/usr/share/doc/blt-2.4/html/vector.html
/usr/share/doc/blt-2.4/html/watch.html
/usr/share/doc/blt-2.4/html/winop.html
# rpm2cpio blt-2.4-14.z.fc6.x86_64.rpm | cpio -it
./usr/lib64/blt2.4
./usr/lib64/blt2.4/bltCanvEps.pro
./usr/lib64/blt2.4/bltGraph.pro
./usr/lib64/blt2.4/dd_protocols
./usr/lib64/blt2.4/dd_protocols/dd-color.tcl
./usr/lib64/blt2.4/dd_protocols/dd-file.tcl
./usr/lib64/blt2.4/dd_protocols/dd-number.tcl
./usr/lib64/blt2.4/dd_protocols/dd-text.tcl
./usr/lib64/blt2.4/dd_protocols/tclIndex
./usr/lib64/blt2.4/dnd.tcl
./usr/lib64/blt2.4/dragdrop.tcl
./usr/lib64/blt2.4/graph.tcl
./usr/lib64/blt2.4/hierbox.tcl
./usr/lib64/blt2.4/hiertable.tcl
./usr/lib64/blt2.4/libBLT24.so
./usr/lib64/blt2.4/libBLTlite24.so
./usr/lib64/blt2.4/pkgIndex.tcl
./usr/lib64/blt2.4/tabnotebook.tcl
./usr/lib64/blt2.4/tabset.tcl
./usr/lib64/blt2.4/tclIndex
./usr/lib64/blt2.4/treeview.tcl
./usr/lib64/blt2.4/treeview.xbm
./usr/lib64/blt2.4/treeview_m.xbm
./usr/share/doc/blt-2.4
./usr/share/doc/blt-2.4/INSTALL
./usr/share/doc/blt-2.4/PROBLEMS
./usr/share/doc/blt-2.4/README
./usr/share/doc/blt-2.4/html
./usr/share/doc/blt-2.4/html/BLT.html
./usr/share/doc/blt-2.4/html/barchart.html
./usr/share/doc/blt-2.4/html/beep.html
./usr/share/doc/blt-2.4/html/bgexec.html
./usr/share/doc/blt-2.4/html/bitmap.html
./usr/share/doc/blt-2.4/html/bltdebug.html
./usr/share/doc/blt-2.4/html/busy.html
./usr/share/doc/blt-2.4/html/container.html
./usr/share/doc/blt-2.4/html/cutbuffer.html
./usr/share/doc/blt-2.4/html/dragdrop.html
./usr/share/doc/blt-2.4/html/eps.html
./usr/share/doc/blt-2.4/html/graph.html
./usr/share/doc/blt-2.4/html/hierbox.html
./usr/share/doc/blt-2.4/html/hiertable.html
./usr/share/doc/blt-2.4/html/htext.html
./usr/share/doc/blt-2.4/html/spline.html
./usr/share/doc/blt-2.4/html/stripchart.html
./usr/share/doc/blt-2.4/html/table.html
./usr/share/doc/blt-2.4/html/tabset.html
./usr/share/doc/blt-2.4/html/tile.html
./usr/share/doc/blt-2.4/html/tree.html
./usr/share/doc/blt-2.4/html/treeview.html
./usr/share/doc/blt-2.4/html/vector.html
./usr/share/doc/blt-2.4/html/watch.html
./usr/share/doc/blt-2.4/html/winop.html
4841 blocks
Comment 18 Eric Hopper 2007-04-30 10:54:42 EDT
How bizarre...

The libraries shouldn't be in /usr/lib64/blt2.4/libBLT24.so, the should be in
/usr/lib64/libBLT24.so, but still rpm2cpio gives different results than rpm
-lqp.  That is very strange.

And I get the same result when I build the rpm from scratch with rpmbuild.

But with my .spec file it works perfectly.
Comment 19 Jean-Luc Fontaine 2007-04-30 13:39:36 EDT
# rpm -lqp blt-2.4-14.z.fc6.x86_64.rpm 
...
/usr/lib64/blt2.4/libBLT24.so
/usr/lib64/blt2.4/libBLTlite24.so
...
# rpm2cpio blt-2.4-14.z.fc6.x86_64.rpm | cpio -it
...
./usr/lib64/blt2.4/libBLT24.so
./usr/lib64/blt2.4/libBLTlite24.so
...
These mean the exact same thing...
>The libraries shouldn't be in /usr/lib64/blt2.4/libBLT24.so
Why?
Comment 20 Eric Hopper 2007-04-30 15:33:26 EDT
(In reply to comment #19)
> # rpm -lqp blt-2.4-14.z.fc6.x86_64.rpm 
> ...
> /usr/lib64/blt2.4/libBLT24.so
> /usr/lib64/blt2.4/libBLTlite24.so
> ...
> # rpm2cpio blt-2.4-14.z.fc6.x86_64.rpm | cpio -it
> ...
> ./usr/lib64/blt2.4/libBLT24.so
> ./usr/lib64/blt2.4/libBLTlite24.so
> ...
> These mean the exact same thing...

Oops, I missed to .so files in the first list.  This is quite interesting.  They
do not show up after rpm does the install.

I just realized I'm a total idiot.  The .so files were in /usr/lib64/blt2.4 all
along.  I don't know how I missed them.  :-(  That's very strange.

> >The libraries shouldn't be in /usr/lib64/blt2.4/libBLT24.so
> Why?

OK, this breaks wish, but makes C and C++ programs linked against it work.

I'm sorry for opening this bug.  Omnet++ is a simulation package that uses BLT.
 It wants the header files, and it would really like the library files to be in
/usr/lib.  But Omnet++ has numerous glaring problems with installation.  Some of
the code won't even compile properly in their 'stable' releases until it's patched.

I wrongly assumed that the things it wanted from BLT were how it ought to be
installed standardly.  I was wrong, and should've realized that given how awful
it was in other ways that it wouldn't be any better in this way.

Note You need to log in before you can comment on or make changes to this bug.