Bug 238298 - FC7 Live CD. X will not start on Dell Inspiron 6400 with ATI Radeon Mobility X1400.
FC7 Live CD. X will not start on Dell Inspiron 6400 with ATI Radeon Mobility...
Status: CLOSED DUPLICATE of bug 235066
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 22:14 EDT by Trevor Campbell
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-26 14:08:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.conf on a Thinkpad Z61M (ATI Radeon X1400) (96.93 KB, application/octet-stream)
2007-05-04 11:10 EDT, Florian Sievert
no flags Details
Xorg.0.log file (86.08 KB, text/plain)
2007-05-04 21:24 EDT, Trevor Campbell
no flags Details
Xorg.0.log (87.60 KB, text/plain)
2007-05-09 09:31 EDT, Valentin Guggiana
no flags Details

  None (edit)
Description Trevor Campbell 2007-04-28 22:14:29 EDT
Description of problem:
FC7 Live CD.  X will not start on Dell Inspiron 6400 with ATI Radeon Mobility X1400.
Xorg can't find a suitable mode line.


How reproducible:
Always

Steps to Reproduce:
1. Insert FC7 Live CD and boot computer.
  
Actual results:
X Fails to start

Expected results:
X starts

Additional info:
I was able to work around this (eventually) by editing xorg.conf to add a
suitable monitor section and mode line and updating the screen section.

The hardware has a default resolution of 1280x800, which is not supported by
vesa.  Needs a 1024x768 mode-line (60hz).

I copied mode line from knoppix configuration.
Comment 1 Florian Sievert 2007-04-29 12:28:54 EDT
I can reproduce this problem on my IBM Thinkpad Z61m, so the problem does not
seems to be related to the notebook model itself. My notebook also contains an
ATI Readeon Mobility X1400, but I think the problem might exist on similiar
devices at all.

Xorg fails to find a suiteable resolution and console is switching to pretty big
characters, making it even impossible to read the fails message. After 2 min he
retries and the screen starts to fill with randomly with characters. System
itself seems to be usable after all.
/var/log/Xorg.0.log just contains
(EE) AIGLX: Screen 0 is not DRI capable
but deactivating AIGLX does not solve the problem. I am also pretty sure it is
related to the default resolution and mode-line.

Comment 2 Adam Jackson 2007-05-03 18:20:05 EDT
Please attach the /var/log/Xorg.0.log from the failed startup.
Comment 3 Florian Sievert 2007-05-04 11:10:57 EDT
Created attachment 154131 [details]
Xorg.conf on a Thinkpad Z61M (ATI Radeon X1400)

I am attaching the Xorg.conf of my thinkpad Z61M. The graphic card itself is a
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400.
If more information are needed, please let me know.
Comment 4 Trevor Campbell 2007-05-04 21:24:24 EDT
Created attachment 154187 [details]
Xorg.0.log file

uploaded Xorg.0.log
Comment 5 Valentin Guggiana 2007-05-09 09:31:24 EDT
Created attachment 154390 [details]
Xorg.0.log
Comment 6 Valentin Guggiana 2007-05-09 09:37:59 EDT
I can reproduce it as well on my Dell Inspiron 9400:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400

It prevents me from using the graphical installation. Xorg.0.log (see attachment
154390 [details]) comes from using startx after doing a textual installation.
Comment 7 Adam Jackson 2007-05-26 14:08:51 EDT
This should be fixed as of xorg-11-drv-vesa 1.3.0-6.

*** This bug has been marked as a duplicate of 235066 ***

Note You need to log in before you can comment on or make changes to this bug.