Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 238319 - ACPI battery exception
ACPI battery exception
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
http://dutiih.twi.tudelft.nl/~jonne/t...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-29 05:57 EDT by jonne
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-17 08:56:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jonne 2007-04-29 05:57:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070417 Fedora/2.0.0.3-4.fc7 Firefox/2.0.0.3

Description of problem:
Right after boot 'dmesg' shows ACPI exceptions already. And more and more are added. After some undefined period of time (say about 10 minutes) the system hangs with a kernel oops (probably because of this, haven't been able to copy this exact error yet). The above url shows dmesg output.

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3116.fc7

How reproducible:
Always


Steps to Reproduce:
1. Just boot.
2.
3.

Actual Results:
- Battery is not reckognized correctly.
- System hangs (I'm forced to power off).

Expected Results:
Normal

Additional info:
My Notebook is an Acer Aspire 1640Z.
It worked fine with Fedora Core 6 (but then I had some other problems, which are fixed now :)
Comment 1 Chuck Ebbert 2007-04-30 18:45:22 EDT
There doesn't seem to be any link to dmesg output in the bug report.
Can we get the exact error messages/ oops report?
Comment 2 jonne 2007-05-01 14:32:34 EDT
Sorry, I hid it in the additional bug information (the URL points to it).
I provided three files now:
- One immediately after booting: (has only few errors at the end)
  http://dutiih.twi.tudelft.nl/~jonne/text/dmesg-acer-aspire-1640z-after-boot.txt
- One after some work: (same as in additional bug information)
  http://dutiih.twi.tudelft.nl/~jonne/text/dmesg-acer-aspire-1640.txt
- One immediately after booting with acpi=off:
http://dutiih.twi.tudelft.nl/~jonne/text/dmesg-acer-aspire-1640z-after-boot-acpi-off.txt

I wouldn't know how to copy/paste the final bug, I tried to write something
down, if you need more information, I'll do it in more detail. The beginning
might be chopped of, I could not scroll further up.

Thanks very much for your time! Jonne.

Message from syslogd
----------------[cut here]---------
localhost kernel: invalid opcode 0000 [#1]
localhost kernel: SMP
localhost kernel: CPU: 0
localhost kernel: EIP: 0060:[<c04f56f4>] Not tainted VLI
...
  Call trace:
  ... show_trace_log_lvl ...
  ... show_stack_log_lvl ...
  ... show_registers ...
  ... die ...
  ... do_trap ...
  ... do_invalid_op ...
  ... error_code ...
  ... free_block ...
  ... drain_array ...
  ... cache_reap ...
  ... run_workqueue ...
  ... worker_thread ...
  ... kthread ...
  ... kernel_thread_helper ...
Comment 3 JeeBee 2007-05-10 03:40:09 EDT
Same problem is still existent with this kernel

kernel-2.6.21-1.3144.fc7.i686.rpm
From: http://people.redhat.com/davej/kernels/Fedora/fc7/

Really hope somebody has a workaround or fix for this.
Comment 4 jonne 2007-05-14 12:26:46 EDT
Something changed with this kernel: (though I hope it's not only a change in
debug/verbosity level)

[root@localhost ~]# uname -a
Linux localhost 2.6.21-1.3149.fc7 #1 SMP Fri May 11 12:12:11 EDT 2007 i686 i686
i386 GNU/Linux
[root@localhost ~]# rpm -qa |grep kernel
kernel-devel-2.6.21-1.3149.fc7
kernel-2.6.21-1.3149.fc7

I still get these lines in 'dmesg'
ACPI Exception (battery-0216): AE_SUPPORT, Extracting _BST [20070126]
But they're *not* anymore followed by this:
slab error in verify_redzone_free(): cache `size-64': memory outside object was
overwritten

Battery is still not working correctly.
Here is some (hopefully usuable) additional info:

[root@localhost ~]# cat /proc/acpi/battery/BAT1/state ; echo "return: $?"
present:                 yes
ERROR: Unable to read battery status
return: 0

[root@localhost ~]# grep . /proc/acpi/battery/* -r
/proc/acpi/battery/BAT1/alarm:alarm:                   unsupported
/proc/acpi/battery/BAT1/state:present:                 yes
/proc/acpi/battery/BAT1/state:ERROR: Unable to read battery status
/proc/acpi/battery/BAT1/info:present:                 yes
/proc/acpi/battery/BAT1/info:design capacity:         2000 mAh
/proc/acpi/battery/BAT1/info:last full capacity:      65317 mAh
/proc/acpi/battery/BAT1/info:battery technology:      rechargeable
/proc/acpi/battery/BAT1/info:design voltage:          14800 mV
/proc/acpi/battery/BAT1/info:design capacity warning: 300 mAh
/proc/acpi/battery/BAT1/info:design capacity low:     2612 mAh
/proc/acpi/battery/BAT1/info:capacity granularity 1:  32 mAh
/proc/acpi/battery/BAT1/info:capacity granularity 2:  32 mAh
/proc/acpi/battery/BAT1/info:model number:            12ZL
/proc/acpi/battery/BAT1/info:serial number:           20064
/proc/acpi/battery/BAT1/info:battery type:            LION
/proc/acpi/battery/BAT1/info:OEM info:                SONY
Comment 5 jonne 2007-05-17 03:50:28 EDT
I'm afraid it could also be some hardware problem that occurred when upgrading 
to F7. With the Knoppix dvd (KNOPPIX_V5.1.1DVD-2007-01-04-EN with 2.6.x kernel) 
the same problem arises.
Here's dmesg output: 
 http://dutiih.twi.tudelft.nl/~jonne/text/KNOPPIX_V5.1.1DVD-2007-01-04-EN

Anybody knows what I can do to be sure? Should I replace the battery??
Comment 6 jonne 2007-05-17 03:52:14 EDT
Sorry, typo in the URL, should have been
http://dutiih.twi.tudelft.nl/~jonne/text/dmesg_KNOPPIX_V5.1.1DVD-2007-01-04-EN
in the previous comment.
Comment 7 jonne 2007-05-28 07:31:51 EDT
Same problem occurred with replaced battery. It is a software bug, right?
I know have kernel-2.6.21-1.3194.fc7 and it still shows the battery exception, see:
http://dutiih.twi.tudelft.nl/~jonne/text/dmesg_kernel-2.6.21-1.3194.fc7_28May2007.txt

any advice on what I can try?
Comment 8 jonne 2007-06-17 08:56:42 EDT
I was able to replace the battery with someone elses and that solved the 
problem. Hence, I must conclude it's very likely to be hardware failure.
The battery exception was a good indication for that, so I guess I should not 
have filed this bug report (although such a thing is frustrating and hard to 
check or be sure). So, thanks everybody for helping and I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.