Bug 238329 - [Regression] text modes broken when switching from X
[Regression] text modes broken when switching from X
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-savage (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-29 08:17 EDT by Stefan Becker
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.1.3-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-10 17:10:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server configuration for savage with 1400x1050 LCD (1.14 KB, text/plain)
2007-05-21 16:03 EDT, Stefan Becker
no flags Details
X server logfile with xorg.conf (53.60 KB, text/plain)
2007-05-21 16:04 EDT, Stefan Becker
no flags Details
X server logfile without xorg.conf (fails to start!) (15.66 KB, text/plain)
2007-05-21 16:17 EDT, Stefan Becker
no flags Details
X server logfile with xorg.conf and VT switch (54.21 KB, text/plain)
2007-05-21 22:39 EDT, Stefan Becker
no flags Details

  None (edit)
Description Stefan Becker 2007-04-29 08:17:07 EDT
Description of problem:

After upgrading to F7test4 from FC6 virtual terminals became unusable. You get
corrupted video output when switching from X11.

Version-Release number of selected component (if applicable):
xorg-x11-drv-savage-2.1.2-3.fc7

How reproducible:
Always

Steps to Reproduce:
1. Boot up maschine to runlevel 5 -> X is on vt7
2. login to X
3. switch between vt7 <-> vt1     -> everything OK
4. logout from X                  -> X restarts on vt9, 11 (seems to vary)
5. switch between vtX <-> vt1
  
Actual results:
corrupted video, virtual terminals are unusable.

Expected results:
working text modes

Additional info:
HW: Mitac 8375 laptop with 1400x1050 LCD panel

kernel option: vga=827 for 1400x1050 fb (doesn't really matter, normal VGA is
also broken)

lspci: 01:00.0 VGA compatible controller: S3 Inc. VT8375 [ProSavage8 KM266/KL266]
Comment 1 Joachim Frieben 2007-05-16 08:58:25 EDT
The same for an IBM ThinkPad T23. Using the VESA framebuffer does not bring
any improvement either. In general, after switching more than once to a VT1
and back, then switching to VT1 leaves one with a monitor going to standby
mode. At this point, it also impossible to switch back to VT7.
At least, ctrl-alt-del allows to reboot the machine gracefully. However,
I do not see a regression. Savage VT switching has always been like that for
me.
Comment 2 Matěj Cepl 2007-05-21 11:54:00 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Stefan Becker 2007-05-21 16:03:20 EDT
Created attachment 155125 [details]
X server configuration for savage with 1400x1050 LCD
Comment 4 Stefan Becker 2007-05-21 16:04:29 EDT
Created attachment 155126 [details]
X server logfile with xorg.conf
Comment 5 Stefan Becker 2007-05-21 16:17:20 EDT
Created attachment 155128 [details]
X server logfile without xorg.conf (fails to start!)

X server fails to start without xorg.conf on my system, because it selects
framebuffer device instead of the savage device.

All 3 files are now attached as requested.
Comment 6 Stefan Becker 2007-05-21 16:20:33 EDT
All 3 files are now attached as requested. (Hope it goes to ASSIGNED state now...)
Comment 7 Stefan Becker 2007-05-21 22:39:06 EDT
Created attachment 155147 [details]
X server logfile with xorg.conf and VT switch

Sorry, late at night, forgot to also attach a X server log with an VT switch
that shows the problem. I don't see any error/problem messages there though...
Comment 8 Stefan Becker 2007-11-10 17:10:24 EST
Just updated to F8: problem is gone.

xorg-x11-drv-savage-2.1.3-1.fc8
xorg-x11-server-Xorg-1.3.0.0-33.fc8
Comment 9 Stefan Becker 2007-11-25 02:15:06 EST
FYI: Was probably fixed by this commit included in 2.1.3 release:

<http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-savage.git;a=commit;h=7832dcd82046238d5accb55468c65241f0edc6d0>

Note You need to log in before you can comment on or make changes to this bug.