Bug 238334 - AttributeError: can't set attribute
AttributeError: can't set attribute
Status: CLOSED DUPLICATE of bug 238305
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-29 09:25 EDT by Julius B.
Modified: 2014-01-21 17:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-29 09:27:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julius B. 2007-04-29 09:25:26 EDT
Description of problem:
yum can't do an update

Version-Release number of selected component (if applicable):
3.1.7

How reproducible:
100%

Steps to Reproduce:
1. # yum update|install|remove|...

  
Actual results:
[root@localhost ~]# yum update
Loading "fastestmirror" plugin
Loading "installonlyn" plugin
Loading mirror speeds from cached hostfile
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 82, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 159, in getOptionsConfig
    (opts, self.cmds) = self.optparser.setupYumConfig()
  File "/usr/share/yum-cli/cli.py", line 1134, in setupYumConfig
    self.base.setupProgessCallbacks()
  File "/usr/share/yum-cli/output.py", line 322, in setupProgessCallbacks
    self.repos.setProgressBar(TextMeter(fo=sys.stdout))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 497, in <lambda>
    repos = property(fget=lambda self: self._getRepos(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 348, in _getRepos
    self.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 163, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 83, in postreposetup_hook
    repo.urls = repomirrors[str(repo)]
AttributeError: can't set attribute



Expected results:
proper update
Comment 1 Julius B. 2007-04-29 09:27:27 EDT

*** This bug has been marked as a duplicate of 238305 ***

Note You need to log in before you can comment on or make changes to this bug.