Bug 238370 - Sound problems on 965 Chipset (Intel ICH5 Audio)
Summary: Sound problems on 965 Chipset (Intel ICH5 Audio)
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard   
(Show other bugs)
Version: 6
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-29 21:34 UTC by Ron Askew
Modified: 2016-02-23 08:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 12:02:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I have attached a freshly generated scsconfig.log (47.35 KB, text/plain)
2007-04-29 21:34 UTC, Ron Askew
no flags Details
Strange things in dmesg -- Hope it helps. (37.76 KB, text/plain)
2007-04-30 02:37 UTC, Ron Askew
no flags Details

Description Ron Askew 2007-04-29 21:34:11 UTC
+++ This bug was initially created as a clone of Bug #228589 +++

Description of problem:
On initial installation, sound was working.  After updated to kernel 2944 86x64,
it no longer worked; not even after I switched back to kernel 2798.

I have downloaded and compiled/installed the alsa drivers you suggested in Bug
#228589.  I removed the referenced in /etc/modprobe (which have not been
replaced) -- and still no results.

I do hear a speaker click during boot, just as the udev rules start up.  My
suspicion is that some other process is stepping on the sound card resources. 
But I don't know enough about debugging the kernel to prove it.


I have attached a freshly generated scsconfig.log which shows that the kernel
thinks everything is fine.

Comment 1 Ron Askew 2007-04-29 21:34:11 UTC
Created attachment 153748 [details]
I have attached a freshly generated scsconfig.log

Comment 2 Ron Askew 2007-04-29 21:35:21 UTC
If I knew how to compile the kernel, I would try that!

Comment 3 Ron Askew 2007-04-30 02:37:21 UTC
Created attachment 153756 [details]
Strange things in dmesg -- Hope it helps.

Comment 4 Martin Stransky 2007-05-02 13:49:37 UTC
Try to write these lines to /etc/asound.conf:

#Generated by system-config-soundcard, do not edit by hand
#SWCONF
#DEV 0
defaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0

Comment 5 Ron Askew 2007-05-03 11:59:05 UTC
You can close this bug. I will open check back when I can get closer to an answer.

I haven't determined the cause, but some process was stepping on either of the
alsa-lib or snd-intel8x0 kernel drivers.

Most of my installs and updates we batched.  There is no way of knowing what the
process was.

I've reinstalled Linux and turned on desktop sounds so I will know pretty quick
when the sound fails again.

Comment 6 Martin Stransky 2007-05-03 12:02:25 UTC
okay.


Note You need to log in before you can comment on or make changes to this bug.