Bug 238405 - Changing keyboard layout.
Changing keyboard layout.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-30 06:57 EDT by Simon Goodall
Modified: 2013-01-09 23:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 17:19:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 521100 None None None Never

  None (edit)
Description Simon Goodall 2007-04-30 06:57:37 EDT
Description of problem:
The livecd does not make it easy to change the keyboard layout. Setting the
language to english (UK) still kept the USA layout.
I had to manually find and load in the keyboard settings applet, then manually
load in and change to the UK layout.
This applet should probably be started by default and have some default layouts
pre-loaded.

Version-Release number of selected component (if applicable):
FC7-test4 livecd

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2007-04-30 14:32:44 EDT
You should be able to just go to Preferences->Hardware->Keyboard to chnage your
keyboard layout.

But I agree it would be ideal if you could do this from the login screen as well
(since you can do language and AT support there)
Comment 2 Simon Goodall 2007-04-30 15:08:09 EDT
When I've used knoppix in the past, I can either set the lang/keyboard on the
bootloader command line by adding lang=uk and the desktop has a nice, easily
noticable applet to change the keyboard.
I do not think going through pref/hw/kb menu options is too intuitive for new
users trying out the desktop.
Comment 3 Jeremy Katz 2007-04-30 15:31:45 EDT
(In reply to comment #2)
> When I've used knoppix in the past, I can either set the lang/keyboard on the
> bootloader command line by adding lang=uk and the desktop has a nice, easily
> noticable applet to change the keyboard.

I don't think that adding random options on the bootloader command line is all
that intuitive either :-)  It really should be well-integrated at login time
where you select things like your language from a nice, graphical and accessible
menu.
Comment 4 jmccann 2008-03-07 17:19:38 EST
Would be good to have this.  Filed upstream.

Note You need to log in before you can comment on or make changes to this bug.