Bug 238493 - Backwards text when editing new configure file under Autotools Plugin
Summary: Backwards text when editing new configure file under Autotools Plugin
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-cdt   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnston
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-30 20:57 UTC by Jeff Johnston
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 21:02:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Johnston 2007-04-30 20:57:08 UTC
When a configure.ac or configure.in file is opened new in an Autotools project,
if the first lines are comments (e.g. dnl abcd or # abcdef), editing the last
line causes characters to appear in reverse order.  An exception may occur
trying to delete these characters.

Comment 1 Jeff Johnston 2007-04-30 21:02:04 UTC
The problem existed in a custom editor rule added by Autotools that was not
properly checking for EOF in the scanner.  A fix has been made so this problem
does not occur.  A temporary workaround to the problem is to add a blank line at
the top of the new file.  This problem does not occur for existing configure files.


Note You need to log in before you can comment on or make changes to this bug.