Bug 238502 - cal -3 format is wrong
cal -3 format is wrong
Status: CLOSED DUPLICATE of bug 213253
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
4
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-30 17:25 EDT by A. Non
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 18:32:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A. Non 2007-04-30 17:25:13 EDT
Description of problem:
The format from "cal -3" that I get on April 30, 2007 is wrong.  There are seven
missing spaces between the "30" in April and the "27" in May:
% cal -3
     March 2007            April 2007             May 2007      
Su Mo Tu We Th Fr Sa  Su Mo Tu We Th Fr Sa  Su Mo Tu We Th Fr Sa
             1  2  3   1  2  3  4  5  6  7         1  2  3  4  5
 4  5  6  7  8  9 10   8  9 10 11 12 13 14   6  7  8  9 10 11 12
11 12 13 14 15 16 17  15 16 17 18 19 20 21  13 14 15 16 17 18 19
18 19 20 21 22 23 24  22 23 24 25 26 27 28  20 21 22 23 24 25 26
25 26 27 28 29 30 31  29 30          27 28 29 30 31      
                                                                
There are 10 spaces instead of 17.

Version-Release number of selected component (if applicable):
% cal -V
cal from util-linux-2.12p
% cat /etc/redhat-release 
Fedora Core release 4 (Stentz)

How reproducible:
Just use "cal -3" (though it may be sensitive to today's date since the inverse
video is the last thing before the formatting problem)


Steps to Reproduce:
1. cal -3
2.
3.
  
Actual results:
     March 2007            April 2007             May 2007      
Su Mo Tu We Th Fr Sa  Su Mo Tu We Th Fr Sa  Su Mo Tu We Th Fr Sa
             1  2  3   1  2  3  4  5  6  7         1  2  3  4  5
 4  5  6  7  8  9 10   8  9 10 11 12 13 14   6  7  8  9 10 11 12
11 12 13 14 15 16 17  15 16 17 18 19 20 21  13 14 15 16 17 18 19
18 19 20 21 22 23 24  22 23 24 25 26 27 28  20 21 22 23 24 25 26
25 26 27 28 29 30 31  29 30          27 28 29 30 31      

Expected results:
     March 2007            April 2007             May 2007      
Su Mo Tu We Th Fr Sa  Su Mo Tu We Th Fr Sa  Su Mo Tu We Th Fr Sa
             1  2  3   1  2  3  4  5  6  7         1  2  3  4  5
 4  5  6  7  8  9 10   8  9 10 11 12 13 14   6  7  8  9 10 11 12
11 12 13 14 15 16 17  15 16 17 18 19 20 21  13 14 15 16 17 18 19
18 19 20 21 22 23 24  22 23 24 25 26 27 28  20 21 22 23 24 25 26
25 26 27 28 29 30 31  29 30                 27 28 29 30 31      

Additional info:
I tried on both rxvt and xterm and gnome-terminal in case the terminal's inverse
video had something to do with it.  Same result on all.  I did it from inside an
emacs shell and May 27 is in the right place, but April 30 doesn't print
properly, but I assume that's an emacs problem.
Comment 1 Karel Zak 2007-04-30 18:32:53 EDT

*** This bug has been marked as a duplicate of 213253 ***

Note You need to log in before you can comment on or make changes to this bug.