Bug 238529 - autofs can return incorrect status from mount under heavy load
Summary: autofs can return incorrect status from mount under heavy load
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ian Kent
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 425907
TreeView+ depends on / blocked
 
Reported: 2007-05-01 06:05 UTC by Ian Kent
Modified: 2008-05-21 14:37 UTC (History)
2 users (show)

Fixed In Version: RHBA-2008-0354
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 14:37:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0354 normal SHIPPED_LIVE autofs bug fix and enhancement update 2008-05-20 12:52:25 UTC

Description Ian Kent 2007-05-01 06:05:52 UTC
Description of problem:

During heavy mount and umount activity it is possible
foe the /etc/mtab to get out of sync with what is
actually mounted. This issue was resolved in autofs
version 4 in RHEL-3 and 4 by changing autofs to use
/proc/mounts instead of /etc/mtab.

This approach isn't feasible in version 5 because of
the possibility of there being many more entries in
/proc/mounts than in /etc/mtab leading to performance
issues given the heavy use of checking the mount table.

The approach to be used in version 5 is to use the return
code from mount to check that the mtab has been updated
and if not call mount again to allow the mtab update.

How reproducible:
With difficulty.

Steps to Reproduce:
To be determined from upstream reports as part of
verification.

Comment 1 RHEL Product and Program Management 2007-05-01 06:23:58 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Ian Kent 2007-05-04 06:50:59 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #0)
> > > How reproducible:
> > > With difficulty.
> > > 
> > > Steps to Reproduce:
> > > To be determined from upstream reports as part of verification.
> > 
> > Would you provide a few pointers?
> 
> Yes, sorry about the vague nature of this bug.
> 
> The reason I logged this bug is that we've seen this very
> often and so I fixed it upstream. Version 5 requires a
> different approach to version 4.

See bugs 191210 and 191213 for RHEL3 and 220506 for RHEL-4.

It is a bit harder to trigger in version 5 but I should be
able to construct a reproducer out of these bugs.

Ian


Comment 11 RHEL Product and Program Management 2007-06-27 12:23:30 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 16 RHEL Product and Program Management 2007-10-16 04:01:09 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 22 errata-xmlrpc 2008-05-21 14:37:23 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0354.html



Note You need to log in before you can comment on or make changes to this bug.