Bug 238538 - Installation aborts - Error informing the kernel about modifications to partition
Installation aborts - Error informing the kernel about modifications to parti...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 04:34 EDT by Michael Roeder
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 11:02:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Roeder 2007-05-01 04:34:28 EDT
Description of problem:

(Similar to Bugzilla Bug 238100)

Trying to install on a hard disk with more then 15 partitions, there won't be
enough devices and the installation will abort after manual partitioning - the
hdd was already partitioned, only the mount points and format option was chosen.

Message:
"Error informing the kernel about modifications to partition /dev/sdb16 -- das
Argument ist ungültig." [[i.e. the argument is not valid]]  
"This means Linux won't know about changes you made to /dev/sdb16 until you
reboot - so you shouldn't mount it or use it in any way before rebooting."

"An unhandled exception has occured.

File /usr/lib/anaconda/partedUtility.py, line 889, in savePartitions disk_commit()
....
....
Install exited abnormally [1/1]"

The problem is that there are partitions that can't be handled.
I've created the devices, but i was not able to tell the kernel and the
installation procedure that there are some new sdb16 and so on. (how to reread???)
The installation partitions were sdb7 (/boot) and sdb12 (/).

Version-Release number of selected component (if applicable):
F-6.92-i386-DVD

How reproducible:
Create 16 partitions on a hdd and try to install

Steps to Reproduce:
1. Create 16 paratitions on a harddisk
2. Run Fedora installer
3. Look that there are /dev/sdb1 until /dev/sdb15, /dev/sdb16 will be missing
4. Choose manual partitioning
5. Create installation mount points
6. Commit
  
Actual results:
Install aborts with above-mentioned error

Expected results:
1. Create enough devices before the parted GUI is envoked
2. Reread manually created devices

Additional info:
Fedora 6.92 installation not possible.
Comment 1 David Cantrell 2007-05-03 11:02:14 EDT
This is fixed in rawhide.  You cannot have more than 15 partitions per disk and
in cases where you already have that, anaconda will now check for that and warn
you about having to reboot to make partition table changes.

Note You need to log in before you can comment on or make changes to this bug.