Bug 238570 - HP5750: CDROM generates errors on tray open & close
Summary: HP5750: CDROM generates errors on tray open & close
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Prarit Bhargava
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
: 244039 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-01 15:06 UTC by Prarit Bhargava
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-11-07 19:48:29 UTC


Attachments (Terms of Use)
RHEL5 fix for this issue (2.16 KB, patch)
2007-05-07 16:38 UTC, Prarit Bhargava
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Prarit Bhargava 2007-05-01 15:06:10 UTC
Description of problem:

When mount /dev/cdrom on the 5750, SATA enters error handling.  The DVD|CD does
mount though.

Version-Release number of selected component (if applicable): RHEL5 GA kernel


How reproducible: 50%


Steps to Reproduce:
1. Boot.
2. mount /dev/cdrom to_some_arbitrary_mount_point
  
Actual results:

May  1 05:06:12 dhcp83-70 kernel: ata2: soft resetting port
May  1 05:06:12 dhcp83-70 kernel: ata2: SATA link up 1.5 Gbps (SStatus 113 SCont
rol 300)
May  1 05:06:12 dhcp83-70 kernel: ata2.00: configured for UDMA/100
May  1 05:06:12 dhcp83-70 kernel: ata2: EH complete
May  1 05:06:13 dhcp83-70 kernel: ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x
800 action 0x2
May  1 05:06:13 dhcp83-70 kernel: ata2.00: (irq_stat 0x40000001)
May  1 05:06:13 dhcp83-70 kernel: ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 e
rr 0x20 (internal error)
May  1 05:06:13 dhcp83-70 kernel: ata2: soft resetting port
May  1 05:06:13 dhcp83-70 kernel: ata2: SATA link up 1.5 Gbps (SStatus 113 SCont
rol 300)
May  1 05:06:13 dhcp83-70 kernel: ata2.00: configured for UDMA/100
May  1 05:06:13 dhcp83-70 kernel: ata2: EH complete
May  1 05:06:14 dhcp83-70 kernel: ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x
800 action 0x2
May  1 05:06:14 dhcp83-70 kernel: ata2.00: (irq_stat 0x40000001)
May  1 05:06:14 dhcp83-70 kernel: ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 e
rr 0x20 (internal error)
May  1 05:06:14 dhcp83-70 kernel: ata2: soft resetting port

Expected results:  No errors should be seen.


Additional info:  5750 is in Prarit's office.

Comment 1 Prarit Bhargava 2007-05-01 16:04:42 UTC
Actually the errors do not occur on the _mount_.  They occur when the CD tray is
opened and closed.

P.

Comment 2 Prarit Bhargava 2007-05-01 16:05:52 UTC
Adding Conke & Bhavana as they have had experience with this chipset.

Conke, I just found this issue this AM -- any ideas?

P.

Comment 3 Prarit Bhargava 2007-05-01 17:29:46 UTC
Errors at runtime on open & close of CD tray:


 ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x800 action 0x2
ata2.00: (irq_stat 0x40000001)
ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 err 0x20 (internal error)
ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x800 action 0x2
ata2.00: (irq_stat 0x40000001)
ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 err 0x20 (internal error)
ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x800 action 0x2
ata2.00: (irq_stat 0x40000001)
ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 err 0x20 (internal error)
ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x800 action 0x2
ata2.00: (irq_stat 0x40000001)
ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 err 0x20 (internal error)
ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x800 action 0x2
ata2.00: (irq_stat 0x40000001)
ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 err 0x20 (internal error)
ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x800 action 0x2
ata2.00: (irq_stat 0x40000001)
ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 err 0x20 (internal error)
ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x800 action 0x2
ata2.00: (irq_stat 0x40000001)
ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 err 0x20 (internal error)
ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x800 action 0x2
ata2.00: (irq_stat 0x40000001)
ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 err 0x20 (internal error)
ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x800 action 0x2
ata2.00: (irq_stat 0x40000001)
ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 err 0x20 (internal error)
ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x800 action 0x2
ata2.00: (irq_stat 0x40000001)
ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 err 0x20 (internal error)
ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x800 action 0x2
ata2.00: (irq_stat 0x40000001)
ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 err 0x20 (internal error)
ata2.00: exception Emask 0x40 SAct 0x0 SErr 0x800 action 0x2
ata2.00: (irq_stat 0x40000001)
ata2.00: tag 0 cmd 0xa0 Emask 0x40 stat 0x51 err 0x68 (internal error)


Comment 4 Prarit Bhargava 2007-05-07 15:49:44 UTC
Backport of http://lkml.org/lkml/2007/4/11/356 resolves this issue.

Note that board_ahci_sb600 = 2 because of missing patchsets for other HW.

P.

Comment 5 Prarit Bhargava 2007-05-07 16:38:34 UTC
Created attachment 154277 [details]
RHEL5 fix for this issue

Comment 6 RHEL Product and Program Management 2007-05-07 16:42:04 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 7 henry su 2007-05-09 11:11:30 UTC
This issue is fixed in the latest kernel version(2.6.21), and the patch 
attached in comment #5 by prarit can fix this issue too.

Comment 8 Don Zickus 2007-06-12 19:01:57 UTC
in 2.6.18-24.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 9 Prarit Bhargava 2007-06-14 14:21:31 UTC
*** Bug 244039 has been marked as a duplicate of this bug. ***

Comment 13 errata-xmlrpc 2007-11-07 19:48:29 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.