Bug 238578 - ifup-aliases cannot deal with onboot ifup-post does not pass boot option
ifup-aliases cannot deal with onboot ifup-post does not pass boot option
Status: CLOSED DUPLICATE of bug 90231
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 12:20 EDT by Timothy
Modified: 2014-03-16 23:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 12:47:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy 2007-05-01 12:20:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070310 Iceweasel/2.0.0.3 (Debian-2.0.0.3-2)

Description of problem:
Interface aliases ignore the "ONBOOT" option in the interface definition file.

ifup-post needs to be updated from
if [ "$ISALIAS" = no ] ; then
    /etc/sysconfig/network-scripts/ifup-aliases ${DEVICE} ${CONFIG}
fi


to
if [ "$ISALIAS" = no ] ; then
    /etc/sysconfig/network-scripts/ifup-aliases ${DEVICE} ${CONFIG} $2
fi

ifup-aliases needs the following

line 71
BOOTFLAG=$3

line 291
##echo "starting onboot code"
if [ "foo$BOOTFLAG" = "fooboot" ] && [ "${ONBOOT}" = "no" -o "${ONBOOT}" = "NO" ]
then
    setup_this=no
fi


Version-Release number of selected component (if applicable):
initscripts-8.31.6-1

How reproducible:
Always


Steps to Reproduce:
1.altered ifcfg-eth0:1
2. to include ONBOOT=no
3.rebooted
tried fresh install with yum update

Actual Results:
interface aliases will always be up no matter what ONBOOT is set to

Expected Results:
interface aliases should be down

Additional info:
Comment 1 Bill Nottingham 2007-05-01 12:47:58 EDT

*** This bug has been marked as a duplicate of 90231 ***

Note You need to log in before you can comment on or make changes to this bug.