Bug 23866 - Strange package size... plz check!
Strange package size... plz check!
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-12 09:22 EST by Need Real Name
Modified: 2016-11-24 10:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-12 10:34:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-12 09:22:14 EST
Before installing the new packages (glibc-2.2-12) I looked at the package
sizes. The new packages are 4Mb while the original was 9Mb and the latest
update before this one even 13Mb. I don't trust this new update and will
only install after a statement that it is safe and bugfree.
Normally such size changes are implying big changes. But I can hardly
believe such things for an established package as the C-Library..

ps. this is filed as a bug for there is no other appearent way to ask these
questions, and if it turns out a bug it could have disastrous consequences.
Comment 1 Jakub Jelinek 2001-01-12 10:34:13 EST
The former glibc package was split into glibc and glibc-common (the reason
behind this is to save space, because glibc-common can be shared between
e.g. i386 and i686, alpha and alphaev6, sparc and sparcv9).
glibc-2.2-9.i386.rpm was ~13M, glibc-2.2-12.i386.rpm is ~4.5M and
glibc-common-2.2-12.i386.rpm is ~6M, so the actual size difference is not that
big and is caused by hardlinking identical /usr/lib/locale/ data files between
various locales (that saved ~20M in the installed size and ~2.5M in the rpm).
Comment 2 Jakub Jelinek 2001-01-12 10:37:12 EST
Oh, one more thing, if you want to install a bugfree glibc, I'm afraid you'll
have to wait forever, software package of this size will never be bugfree.
I can just assure you this package was tested by myself and our QA and seems
to be ok.
Comment 3 Need Real Name 2001-01-13 11:43:26 EST
Who was talking about bugfree software? I don't expect bugfree software, 
because there is no such thing as bugfree software. It performs okay, but 
software is never finished and will always run in to bugs somewhere up the road.
Just being cautious with software updates for some of my systems.

Note You need to log in before you can comment on or make changes to this bug.