Bug 238686 - Strange syslog performance with sldap log (had been fixed in FC6,but RHEL5 is not)
Strange syslog performance with sldap log (had been fixed in FC6,but RHEL5 is...
Status: CLOSED DUPLICATE of bug 235964
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openldap (Show other bugs)
5.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 06:10 EDT by Ching-Che Yen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-02 07:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ching-Che Yen 2007-05-02 06:10:45 EDT
Description of problem:

I had posted this one Bugzilla Bug:
Bugzilla Bug 235964: poor openldap performance on HP dl320 and dl380 G4 G5 and dl585

I found that on some hardware platform(HP DL360 DL380 DL585,IBM 336),
if you add "local4.*     /var/log/ldap.log" to let the syslog to handle the log
from slapd,the performance of slapd is very bad.

if you disable it,and redirect the log of slapd with command "slapd -d 512 >>
/var/log/ldap.log" while you start the slapd service,the performance of slapd is
good.

These days, this problem was been fixed in fedora core 6 by updating rpms.
But I could not find out which rpm fixed this problem.


This is the list of updated rpms.

Apr 11 03:06:32 Updated: samba-common.i386 3.0.24-4.fc6
Apr 11 03:06:32 Updated: libXfont.i386 1.2.8-1.fc6
Apr 11 03:06:34 Updated: yum.noarch 3.0.5-2.fc6
Apr 11 03:06:35 Updated: samba-client.i386 3.0.24-4.fc6
Apr 11 03:06:35 Updated: iputils.i386 20070202-2.fc6
Apr 11 03:06:36 Updated: libXfont-devel.i386 1.2.8-1.fc6
Apr 11 03:06:37 Updated: yum-updatesd.noarch 3.0.5-2.fc6
Apr 11 03:06:42 Updated: samba.i386 3.0.24-4.fc6
Apr 11 03:06:44 Updated: dhclient.i386 12:3.0.5-4.fc6
Apr 13 03:03:54 Updated: libX11.i386 1.0.3-7.fc6
Apr 13 03:03:55 Updated: xorg-x11-server-Xorg.i386 1.1.1-47.8.fc6
Apr 13 03:03:56 Updated: system-config-printer-libs.i386 0.7.52.1-2.fc6
Apr 13 03:03:58 Updated: selinux-policy.noarch 2.4.6-54.fc6
Apr 13 03:04:00 Updated: libX11-devel.i386 1.0.3-7.fc6
Apr 13 03:04:02 Updated: system-config-printer.i386 0.7.52.1-2.fc6
Apr 13 03:04:08 Updated: selinux-policy-targeted.noarch 2.4.6-54.fc6
Apr 14 03:04:08 Updated: subversion.i386 1.4.3-2.fc6
Apr 14 03:04:09 Updated: lftp.i386 3.5.9-0.fc6
Apr 14 03:04:09 Updated: iputils.i386 20070202-3.fc6
Apr 14 03:04:10 Updated: tar.i386 2:1.15.1-25.fc6
Apr 15 03:05:30 Updated: kernel-headers.i386 2.6.20-1.2944.fc6
Apr 15 03:05:38 Installed: kernel.i586 2.6.20-1.2944.fc6
Apr 15 03:05:49 Updated: kernel-devel.i586 2.6.20-1.2944.fc6
Apr 19 03:05:08 Updated: php-common.i386 5.1.6-3.5.fc6
Apr 19 03:05:09 Updated: php-cli.i386 5.1.6-3.5.fc6
Apr 19 03:05:10 Updated: yum.noarch 3.0.6-1.fc6
Apr 19 03:05:18 Updated: gtk2.i386 2.10.8-3.fc6
Apr 19 03:05:18 Updated: php-ldap.i386 5.1.6-3.5.fc6
Apr 19 03:05:19 Updated: yum-updatesd.noarch 3.0.6-1.fc6
Apr 19 03:05:20 Updated: php.i386 5.1.6-3.5.fc6
Apr 20 03:07:04 Updated: coreutils.i386 5.97-12.5.fc6
Apr 20 03:07:05 Updated: tcp_wrappers.i386 7.6-40.3.fc6
Apr 20 03:07:07 Updated: selinux-policy.noarch 2.4.6-57.fc6
Apr 20 03:07:13 Updated: selinux-policy-targeted.noarch 2.4.6-57.fc6
Apr 26 03:04:28 Updated: httpd.i386 2.2.4-1.fc6
Apr 26 03:04:30 Updated: dovecot.i386 1.0.0-3.fc6
Apr 26 03:04:32 Updated: policycoreutils.i386 1.34.1-7.fc6
Apr 26 03:04:33 Updated: m4.i386 1.4.8-2
Apr 26 03:04:33 Updated: xterm.i386 225-1.fc6
Apr 26 03:04:34 Updated: mod_ssl.i386 1:2.2.4-1.fc6
Apr 26 03:04:35 Updated: httpd-manual.i386 2.2.4-1.fc6
Apr 29 03:03:43 Updated: avahi.i386 0.6.16-4.fc6
Apr 29 03:03:44 Updated: avahi-glib.i386 0.6.16-4.fc6
Apr 29 03:03:45 Updated: system-config-date.noarch 1.8.12-2.fc6

In order to find out which rpm fiexd this problem,
I have tried to reinstall the old tcp_wrapper,but the performance of ldap is
still good.

And the system is not been reboot these days,so the system still running with
older kernel(last version 2.6.20-1.2933.fc6 ).

Thank you very much and sorry for my poor english
Comment 1 Jan Safranek 2007-05-02 07:04:39 EDT

*** This bug has been marked as a duplicate of 235964 ***

Note You need to log in before you can comment on or make changes to this bug.