Bug 238690 - pm-hibernate fails in shutting down a Dell OPTIPLEX GX280
pm-hibernate fails in shutting down a Dell OPTIPLEX GX280
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 07:43 EDT by Steven Op de beeck
Modified: 2015-03-04 20:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 04:13:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
extract of kernel messages, seems to be of restore, nothing on actual hibernate itself (8.60 KB, text/plain)
2007-05-02 07:43 EDT, Steven Op de beeck
no flags Details

  None (edit)
Description Steven Op de beeck 2007-05-02 07:43:12 EDT
Description of problem:

pm-hibernate fails in shutting down the machine. A lot of status msgs appear
concerning shrinking memory, etc. After the messages that says 'syncing [...]
sda [...]' the system stays at message indefinately and starts using cpu cycles,
as I can hear from the cpu-fans that start blowing faster.

After manually resetting the machine it returns from hibernate, and restores the
system to the state before hibernating.

pm-hibernate worked in fc6.

Version-Release number of selected component (if applicable):
pm-utils-0.99.3-2.fc7

How reproducible:
run pm-hibernate in terminal, or click the hibernate button in gnome.

Steps to Reproduce:
1. hibernate the machine using pm-hibernate
2. wait for machine to shutdown
  
Actual results:
- machine starts eating cpu
- required to manually reset machine
- recovers from hibernate as expected after being switched on

Expected results:
- machine shuts down automatically
- recovers from hibernate as expected after being switched on

Additional info:
machine:
Dell OPTIPLEX GX280
3.2Ghz, 1GiB RAM
80GB harddisk on /dev/sda
selinux enabled in permissive mode
kernel-2.6.21-1.3116.fc7 (same behavior with earlier fc7 kernels, I started from
test3)
bios set to S3
Comment 1 Steven Op de beeck 2007-05-02 07:43:13 EDT
Created attachment 153932 [details]
extract of kernel messages, seems to be of restore, nothing on actual hibernate itself
Comment 2 Steven Op de beeck 2007-05-02 07:45:28 EDT
Comment on attachment 153932 [details]
extract of kernel messages, seems to be of restore, nothing on actual hibernate itself

fixed mime-type
Comment 3 Richard Hughes 2007-05-24 08:07:34 EDT
Can you try some of the quirks in
http://people.freedesktop.org/~hughsient/quirk/ please - thanks!
Comment 4 Steven Op de beeck 2007-05-24 10:05:20 EDT
I tried pm-hibernate just now, and it seems to work fine. Clean hibernate,
shutdown and thaw.

However, while reading the quirks-website, I noticed pm-suspend doesn't succeed
in returning from suspend. I tried some combinations of parameters, but nothing
seemed to work, until I got tired of force-shutdowning my pc.

I noticed both S3-related params result in a complete shutdown. 

On a rare occasion I am able to login through ssh and reboot, other times the
monitor stays off and the pc doesn't respond to anything (including ping).

I will do some testing later. The quirks-site seems down for the moment.
Comment 5 Till Maas 2007-09-13 01:31:00 EDT
(In reply to comment #4)

> I will do some testing later. The quirks-site seems down for the moment.

Did you do more testing? Does it work now?
Comment 6 Till Maas 2008-01-08 11:36:57 EST
Steven, can you please test, whether it does still not work for you? I cannot
check this, because I do not have access to a notebook like yours.
Comment 7 Steven Op de beeck 2008-01-28 18:08:58 EST
The machine is a desktop computer at my work. Hibernate still works fine.
Suspend has the same problem. I did not re-try the quirks. When I find the time,
in the next two weeks, I will look into this.
Comment 8 Steven Op de beeck 2008-04-08 04:13:46 EDT
On a completely update F7 using the ATI radeon driver, both suspend and hibernate appear to be working 
correctly.

Note You need to log in before you can comment on or make changes to this bug.