Bug 238713 - Shouldn't /etc/init.d/dhcdbd remove /var/lock/subsys/dhcdbd?
Summary: Shouldn't /etc/init.d/dhcdbd remove /var/lock/subsys/dhcdbd?
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcdbd   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-02 15:04 UTC by Tom London
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 20:25:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom London 2007-05-02 15:04:13 UTC
Description of problem:
Looks like /etc/init.d/dhcdbd is not removing /var/lock/subsys/dhcdbd when
stopping the service. 

This causes 'killall' to try to stop it again, with a nice red FAILED message on
the screen during shutdown.

Would this fix it:

--- dhcdbd.old  2007-04-26 11:15:16.000000000 -0700
+++ dhcdbd      2007-05-02 07:57:15.000000000 -0700
@@ -50,6 +50,7 @@
         echo
     fi
 
+    rm -f $lockfile
     return $RETVAL
 }
 


Version-Release number of selected component (if applicable):
dhcdbd-2.7-3.fc7

How reproducible:
every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2007-05-02 16:52:24 UTC
Sorry, this has 'gone away'.

Sorry for the noise.

Comment 2 David Cantrell 2007-05-03 20:25:30 UTC
Fixed in dhcdbd-2.7-4.fc7


Note You need to log in before you can comment on or make changes to this bug.