Bug 238732 - Numerous configuration errors reported by Product Configuration Manager
Numerous configuration errors reported by Product Configuration Manager
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 13:13 EDT by Edward Hildum
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 02:52:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 162798 None None None Never

  None (edit)
Description Edward Hildum 2007-05-02 13:13:57 EDT
Description of problem:
On a fresh install of eclipse 3.2.2-2 and after updating to eclipse 3.2.2-5,
many of the installed resources are flagged in the Product Configuration manager
as having missing components:
 Eclipse C/C++ Developent Tools 3.1.2.200702271911:
     Plug-in "org.eclipse.cdt.core.linux.x86" version "3.1.2.200702271911" 
     referenced by this feature is missing.
 Eclipse JDT Plug-in Developer Resources 3.2.2.r322_v20070104-R4CR0Znkvtfjv9-:
     Plug-in "org.eclipse.jdt.doc.isv" version "3.2.1.r322_v20070109"
     referenced by this feature is missing.
 Eclipse Platform 3.2.2.r322_v20070119-CXMbUe9K_WF26uA:
     Plug-in "org.eclipse.help.webapp" version "3.2.2.R322_v20061114"
     referenced by this feature is missing.

     Plug-in "org.eclipse.core.filesystem.linux.x86" version "1.0.0.v20060603"
     referenced by this feature is missing.

     Plug-in "org.eclipse.update.core.linux" version "3.2.0.v20060605"
     referenced by this feature is missing.

     Included feature "org.eclipse.rcp_3.2.2.r322_v20070104-iwP0VLKnfFC923K"
     is missing.
 Eclipse Platform Plug-in Developer Resources 3.2.2.r322_v20070119-CXMbUe9K_WF26uA:
     Plug-in "org.eclipse.platform.doc.isv" version "3.2.2.R32x_v20070115"
     referenced by this feature is missing.

     Plug-in "org.eclipse.platform.source" version 
     "3.2.2.r322_v20070119-CXMbUe9K_WF26uA" referenced by this feature is
     missing.

     Plug-in "org.eclipse.platform.source.linux.gtk.x86" version 
     "3.2.2.r322_v20070119-CXMbUe9K_WF26uA" referenced by this feature is 
     missing.

     Included feature "Eclipse RCP Plug-in Developer Resources" version 
     "3.2.2.r322_v20070104-iwP0VLKnfFC923K" contains problems.
 Eclipse Platform Plug-in Developer Resources 3.2.2.r322_v20070104-iwP0VLKnfFC923K:
     Plug-in "com.ibm.icu.source" version "3.4.5.20061213" referenced by this
     feature is missing.

     Plug-in "org.eclipse.rcp.source.linux.gtk.x86" version 
     "3.2.2.r322_v20070104-iwP0VLKnfFC923K" referenced by this feature is 
     missing.
 Eclipse Plug-in Development Environment 3.2.1.r321_v2006082-6vYLLdQ3Nk8DrFG:
     Plug-in "org.eclipse.pde.doc.user" version "3.2.1.v20060816-0800"
     referenced by this feature is missing.
 Eclipse Project SDK 3.2.2.r322_v20070104-OlsEN15kfLend_i:
     Included feature 
     "org.eclipse.platform_3.2.2.r322_v20070119-CXMbUe9K_WF26uA" is missing.

     Included feature 
     "org.eclipse.platform.source_3.2.2.r322_v20070119-CXMbUe9K_WF26uA" is 
     missing.

     Included feature "org.eclipse.jdt_3.2.2.r322_v20070104-R4CR0Znkvtfjv9-" is 
     missing.

     Included feature 
     "org.eclipse.jdt.source_3.2.2.r322_v20070104-R4CR0Znkvtfjv9-" is missing.

     Included feature "org.eclipse.pde_3.2.1.r321_v20060823-6vYLLdQ3Nk8DrFG" is 
     missing.

     Included feature 
     "org.eclipse.pde.source_3.2.1.r321_v20060823-6vYLLdQ3Nk8DrFG" is missing.
 Eclipse RCP 3.2.2.r322_v20070104-iwP0VLKnfFC923K:
     Plug-in "com.ibm.icu" version "3.4.5.20061213" referenced by this feature 
     is missing.

     Plug-in "org.eclipse.core.commands" version "3.2.0.I20060605-1400" 
     referenced by this feature is missing.

     Plug-in "org.eclipse.core.jobs" version "3.2.0.v20060603" referenced by 
     this feature is missing.

     Plug-in "org.eclipse.core.expressions" version "3.2.2.r322_v20070109a" 
     referenced by this feature is missing.

     Plug-in "org.eclipse.core.runtime" version "3.2.0.v20060603" referenced by  
     this feature is missing.

     Plug-in "org.eclipse.core.runtime.compatibility.auth" version 
     "3.2.0.v20060601" referenced by this feature is missing.

     Plug-in "org.eclipse.osgi" version "3.2.2.R32x_v20070118" referenced by 
     this feature is missing.

     Plug-in "org.eclipse.help" version "3.2.2.R322_v20061213" referenced by 
     this feature is missing.

     Plug-in "org.eclipse.swt" version "3.2.2.v3236b" referenced by this feature
     is missing.

     Plug-in "org.eclipse.jface" version "3.2.2.M20061214-1200" referenced by 
     this feature is missing.

     Plug-in "org.eclipse.jface.databinding" version "1.0.0.I20060605-1400"
     referenced by this feature is missing.

     Plug-in "org.eclipse.ui" version "3.2.1.M20061108" referenced by this 
     feature is missing.

     Plug-in "org.eclipse.ui.workbench" version "3.2.2.M20070119-0800" 
     referenced by this feature is missing.

     Plug-in "org.eclipse.update.configurator" version "3.2.2.R32x_v20070111" 
     referenced by this feature is missing.

     Plug-in "org.eclipse.rcp" version "3.2.0.v20060605" referenced by this 
     feature is missing.

     Plug-in "org.eclipse.core.contenttype" version "3.2.0.v20060603" referenced
     by this feature is missing.

     Plug-in "org.eclipse.equinox.common" version "3.2.0.v20060603" referenced 
     by this feature is missing.

     Plug-in "org.eclipse.equinox.preferences" version "3.2.1.R32x_v20060717" 
     referenced by this feature is missing.

     Plug-in "org.eclipse.equinox.registry" version "3.2.1.R32x_v20060814" 
     referenced by this feature is missing.


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Install eclipse 3.2.2 from fedora 6 rpms
2. Start eclipse
3. Go to Help/Software Updates/Manage Configuration
4. Expand /usr/share/eclipse and /usr/lib/eclipse entries
5. Click Show Properites, then Status of red checked items
  
Actual results:
On a fresh install, there should be no configuration errors.

Expected results:
Configuration errors reported.

Additional info:
This may only be a cosmetic bug since the platform does seem to work.  I've only
checked the function of the CDT and SVN plug-ins though.
Comment 1 Ben Konrath 2007-05-03 01:50:27 EDT
This is a known problem and it is mostly cosmetic. See this bug for details:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=162798

Note You need to log in before you can comment on or make changes to this bug.