Bug 238772 - fancontrol initscript never finishes execution
Summary: fancontrol initscript never finishes execution
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: lm_sensors   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-02 21:19 UTC by Stewart Adam
Modified: 2015-03-05 01:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 19:06:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stewart Adam 2007-05-02 21:19:53 UTC
Description of problem:
Running 'service fancontrol start' never finishes, it must be either stopped or
killed. As a result, if this service is enabled the bootup process stops here.

Version-Release number of selected component (if applicable):
lm_sensors-2.10.3-2.fc7

How reproducible:
Always

Steps to Reproduce:
1. $ chkconfig --add fancontrol
2. $ chkconfig fancontrol on
3. Reboot OR $ service fancontrol start
  
Actual results:
fancontrol isn't correctly daemonized so a prompt never returns / boot process stops

Expected results:
It daemonizes

Additional info:

Comment 1 Hans de Goede 2007-07-10 19:06:38 UTC
Hi,

Short introduction, I'm a Fedora contributer and since I'm involved in
lm_sensors upstream, I've also become a co-maintainer of lm_sensors in Fedora.

Fedora's lm_sensors package does not install a fancontrol service. I guess you
installed the fancontrol.init file from /usr/share/doc/lm_sensors-2.10.3 into
/etc/rc.d/init.d yourself? Or did it end up there some otherway ?

Eitherway since we Fedora does not install it, we also do not support it. Please
report this issue upstream to the lm_sensors mailinglist and / or ticket system:
http://lists.lm-sensors.org/mailman/listinfo/lm-sensors
http://www.lm-sensors.org/report/

Thanks!



Note You need to log in before you can comment on or make changes to this bug.