Bug 238783 - unknown username "gdm" in message bus configuration
Summary: unknown username "gdm" in message bus configuration
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
: 240718 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-02 22:14 UTC by Sebastian Vahl
Modified: 2013-03-06 03:50 UTC (History)
3 users (show)

Fixed In Version: 0.2.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 20:47:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sebastian Vahl 2007-05-02 22:14:49 UTC
Description of problem: If gdm is not installed, this error is shown during boot:
"Starting system message bus: unknown username "gdm" in message bus configuration


Version-Release number of selected component (if applicable): ConsoleKit-0.2.1-2.fc7


How reproducible: Use KDE-LiveCd or remove gdm and user "gdm".


Actual results: above error is shown


Expected results: dbus should not complain about this


Additional info: Removing the entry for gdm in
/etc/dbus-1/system.d/ConsoleKit.conf doesn't show the error.

Comment 1 Matthias Clasen 2007-05-03 02:03:02 UTC
Surely thats a dbus bug; it should not complain about unknown users in the policy.

Comment 2 Matthias Clasen 2007-05-22 02:23:13 UTC
*** Bug 240718 has been marked as a duplicate of this bug. ***

Comment 3 Peter Bieringer 2007-08-05 08:55:32 UTC
Happen here also using XFCE.

Comment 4 Sebastian Vahl 2007-09-18 16:33:37 UTC
Is there a chance to fix this one for Fedora 8? 

Comment 5 David Zeuthen 2007-09-18 20:47:34 UTC
Should be fixed in 0.2.2 or later.

Comment 6 Sebastian Vahl 2007-09-19 01:15:57 UTC
Confirmed with ConsoleKit-0.2.3. Thanks!


Note You need to log in before you can comment on or make changes to this bug.