Bug 238811 - Suspend menu items only lock screen
Summary: Suspend menu items only lock screen
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kpowersave   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-03 02:13 UTC by Jason Tibbitts
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 19:50:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Tibbitts 2007-05-03 02:13:28 UTC
I'm testing kpowersave-0.7.2-1.fc7 on an up-to-date rawhide system and for some
reason the menu items "Suspend to Disk" and "Suspend to RAM" merely lock the
screen.  pm-suspend and pm-hibernate both work fine, but I suppose that
kpowersave does some dbus magic to ask HAL to do the suspend, and I've pretty
much no idea how to debug that kind of thing.  (I guess I could run ltrace on
it; I'll try that tomorrow.)

Comment 1 Jason Tibbitts 2007-05-03 19:50:17 UTC
Well, it turns out that this is due to me running an FC6 kernel on F7.  If I
boot the latest kernel from davej's page (3125, I think) kpowersave does what
it's supposed to.  I'm guessing that hal is confused by the kernel mismatch. 
Unfortunately then suspend to RAM is broken, but that's a generic problem with
all of the F7 kernels and seems unrelated to kpowersave.

Sorry for the false alarm.


Note You need to log in before you can comment on or make changes to this bug.