Bug 238831 - text console display bit garbled
text console display bit garbled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
bzcl34nup
:
: 239990 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-03 04:36 EDT by Jens Petersen
Modified: 2008-04-04 00:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 00:41:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
virt-console.png (14.25 KB, image/png)
2007-05-03 04:36 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2007-05-03 04:36:38 EDT
Description of problem:
When using the console in text mode the background is garbled which
makes the text hard to read.

How reproducible:
every time

Steps to Reproduce:
1. start a virtual console from virt-manager
2. look at OS in text console mode
  
Actual results:
garbled background

Expected results:
consistent black background

Additional info:
Works ok in qemu console for instance.
Comment 1 Jens Petersen 2007-05-03 04:36:38 EDT
Created attachment 154011 [details]
virt-console.png
Comment 2 Daniel Berrange 2007-05-03 08:58:02 EDT
This is a bug in the QEMU VNC server I believe. I see the same kind of
corruption when using a regular 'vncviewer' client. It seems to particularly
occur when changing resolutions.
Comment 3 Jens Petersen 2007-05-03 19:42:37 EDT
So it is a qemu bug?
Comment 4 Daniel Berrange 2007-05-03 22:31:38 EDT
This bug is trivially reproducable with current QEMU cvs HEAD, simply by booting
the Fedora Core 6  boot.iso on i386

dd if=/dev/zero of=foo.img bs=1M count=0 seek=1024
qemu -hda foo.img -cdrom boot.iso -boot d -vnc :1 &
vncviewer :1

On the very first text mode switch - from syslinux to booting the kernel, the
pattern shown in #1 will be seen.

I did a quick hack forward porting Xen's  tools/iommu/patches/vnc-fixes  patch
file to work with QEMU & this solved the problem. I'll do a real forward port &
send it to upstream QEMU for comment & attach a version suitable for QEMU 0.9.0
Comment 5 Daniel Berrange 2007-10-04 22:35:22 EDT
*** Bug 239990 has been marked as a duplicate of this bug. ***
Comment 6 Bug Zapper 2008-04-03 20:27:19 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 7 Jens Petersen 2008-04-04 00:41:32 EDT
Thanks, closing - I think this has been fixed for a while. :)

Note You need to log in before you can comment on or make changes to this bug.