Bug 238840 - numactl --show broken for >128 cpus
numactl --show broken for >128 cpus
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: numactl (Show other bugs)
4.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
: 237316 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-03 07:10 EDT by Martin Poole
Modified: 2007-11-16 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0547
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:02:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for >127 cpus (435 bytes, patch)
2007-05-03 07:10 EDT, Martin Poole
no flags Details | Diff

  None (edit)
Description Martin Poole 2007-05-03 07:10:37 EDT
Description of problem:

A recent change that went into numactl for RHEL4 has a limit of 128 cpus.

Version-Release number of selected component (if applicable):

numactl-0.6.4-1.39

How reproducible:

100%


Steps to Reproduce:
1. numactl --show (on a system with >128 cpus)
2.
3.
  
Actual results:

cpubind: field shows cpus 0-127

Expected results:

cpubind field should show cpus 0 - <total on system>

Additional info:

Customer patch attached.
Comment 1 Martin Poole 2007-05-03 07:10:39 EDT
Created attachment 154016 [details]
patch for >127 cpus
Comment 2 RHEL Product and Program Management 2007-06-04 14:25:15 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Neil Horman 2007-06-04 14:31:57 EDT
*** Bug 237316 has been marked as a duplicate of this bug. ***
Comment 4 Neil Horman 2007-06-05 08:36:09 EDT
This is ready to go in, I just need a QA ack on the bug to commit it.
Comment 6 Neil Horman 2007-06-05 13:31:26 EDT
fixed in -1.40.  Thanks!
Comment 7 Doug Chapman 2007-06-07 11:45:37 EDT
Tested on a 256 cpu HP Integrity server.

- Doug
Comment 15 errata-xmlrpc 2007-11-15 11:02:56 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0547.html

Note You need to log in before you can comment on or make changes to this bug.